Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1

    Join Date
    Jan 2013
    Location
    Southern Indiana
    Posts
    52

    12' PX IC Strainer

    Can someone post a pic of where the strainer screen is for the IC? I overheated the exhaust today and need to check this first.


  2. #2
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,073
    +1
    790
    here you go.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_5126.jpg 
Views:	92 
Size:	66.1 KB 
ID:	307483  

  3. #3

    Join Date
    Jan 2013
    Location
    Southern Indiana
    Posts
    52
    Thank you very much sir! I'm going out to the shop right now to check.

  4. #4

    Join Date
    Jan 2013
    Location
    Southern Indiana
    Posts
    52
    I do not see one in that area at all! Is the inlet line coming into the strainer coming off the "T" fitting in the bottom of the hull?

  5. #5
    Joe Stang's Avatar
    Join Date
    Aug 2008
    Location
    Durham, CT
    Posts
    1,928
    +1
    61
    Did you add a strainer to your machine? They do not come stock.

  6. #6

    Join Date
    Jan 2013
    Location
    Southern Indiana
    Posts
    52
    Quote Originally Posted by Joe Stang View Post
    Did you add a strainer to your machine? They do not come stock.
    No I did not. My boat is bone stock. Is the stock IC cooled by engine coolant??

    Thanks for your input.

  7. #7
    C Doo's Avatar
    Join Date
    Mar 2007
    Location
    Perth Australia
    Posts
    387
    +1
    20
    no it takes the water u are riding in

  8. #8

    Join Date
    Jan 2013
    Location
    Southern Indiana
    Posts
    52
    Well yesterday while riding my high exhaust temp light came on, so I idled down and tried to let it cool for a few minutes. Took the seat off and everything was smoking! Do you think I got some vegetation in part of the open loop system somewhere? And if so, what do I need to dissassble to clean?

  9. #9
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Flush it.

  10. #10

    Join Date
    Jan 2013
    Location
    Southern Indiana
    Posts
    52
    Ok guys, just got home from church and hooked the garden hose up and let the gurl idle for a good 5 minutes. Didn't give me and beeps or warning codes. The water coming out of the exhaust was luke-warm. Going to go do a couple hotlaps at the lake and see how it performs. I will post back in a bit. Thanks for the help!

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. '12 PX 260 stock injectors 42 or 48's?
    By Vman in forum 4-Tec Performance
    Replies: 6
    Last Post: 04-18-2012, 07:24 PM
  2. '12 PX Singe Use adjustable sponsoon bolts
    By ds33gt in forum 4-Tec Performance
    Replies: 15
    Last Post: 03-14-2012, 09:41 AM
  3. Pump to IC strainer hose blew
    By JFizzleJR in forum 4-Tec Performance
    Replies: 16
    Last Post: 06-10-2008, 06:38 PM
  4. Groco ic strainer?
    By N8T in forum 4-Tec Performance
    Replies: 7
    Last Post: 03-04-2008, 10:21 AM
  5. how/where is everyone mounting their IC strainers??
    By TorquePhoto in forum 4-Tec Performance
    Replies: 21
    Last Post: 01-06-2007, 11:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •