Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    SLASHER's Avatar
    Join Date
    Jun 2007
    Location
    Australia, Perth WA
    Posts
    3,263
    +1
    474

    Bellow band problems ?

    I just installed a bellow band on my RXTX 260 ...

    has added a heap of tension , I have used one on my RXP but there seems to be more tension ...

    Has any one had any problems on load on the top hat and crank stop end ?


  2. #2

    Join Date
    Sep 2010
    Location
    South Florida
    Posts
    1,599
    +1
    123
    Quote Originally Posted by SLASHER View Post
    I just installed a bellow band on my RXTX 260 ...

    has added a heap of tension , I have used one on my RXP but there seems to be more tension ...

    Has any one had any problems on load on the top hat and crank stop end ?
    Been running one in my 2010 TX for some time now. No issues.... Trying to increase a little more pressure on the carbon seal/hat. Water in these ski has been a problem for some since day one.

  3. #3
    SLASHER's Avatar
    Join Date
    Jun 2007
    Location
    Australia, Perth WA
    Posts
    3,263
    +1
    474
    Quote Originally Posted by Glade Rider View Post
    Quote Originally Posted by SLASHER View Post
    I just installed a bellow band on my RXTX 260 ...

    has added a heap of tension , I have used one on my RXP but there seems to be more tension ...

    Has any one had any problems on load on the top hat and crank stop end ?
    Been running one in my 2010 TX for some time now. No issues.... Trying to increase a little more pressure on the carbon seal/hat. Water in these ski has been a problem for some since day one.


    Iam hearing yah ...

  4. #4
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    No issues from it at all. Tension is your friend Had mine on since they were released, and love it.

  5. +1 by:


  6. #5
    SLASHER's Avatar
    Join Date
    Jun 2007
    Location
    Australia, Perth WA
    Posts
    3,263
    +1
    474
    But too much can put load on the crank and add more stress on the crank trust bearings ....

    But looks like no issue , how about c clip that holds the top hat ?

  7. #6
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    had my lower end apart twice lately for piston issues, and the thrust washers look great! I reused them they were so good.
    I really dont think the boot can put that much pressure on the crank, no matter how much tension is on it. The Prop coming loose, sure could tho.....

    I have a bellow band, on mine with a Thick O-ring behind the boot, BTW....

  8. #7
    TheEngineer's Avatar
    Join Date
    Aug 2007
    Location
    Tampa, FL
    Posts
    934
    +1
    131
    I'm still getting water through my seal on accelleration, probably due to a thru-hull that is slightly out of alignment. Will the bellow band help reduce the water coming through on take off? Sort of as a temporary fix until I work on the thru-hull this winter?

  9. #8
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    are u cavitating bad? It will help some for sure. But since the shaft, and boot have to come out to install it, u may want to replace the accordion boot, and carbon seal too. then u should be good to go for many hours.

  10. #9

    Join Date
    Sep 2012
    Location
    Westchester,NY
    Posts
    172
    +1
    6
    I asked Erik about preload on the hat caused by the bellows band when I got mine. He said it doesn't add any load it just stops the bellows from compressing and losing its spring especially when hot. He does make 2 different size bands, maybe you got the wrong one? I dont know exactly what the size difference is. Been running one for a year now and no problems, carbon seal does not show any signs of premature wear.

  11. #10
    SLASHER's Avatar
    Join Date
    Jun 2007
    Location
    Australia, Perth WA
    Posts
    3,263
    +1
    474
    2 sizes ?.. Didn't know that ...

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Speedfreaks Bellow band thrust washer concern....
    By Snoman in forum 4-Tec Performance
    Replies: 45
    Last Post: 09-07-2011, 10:03 PM
  2. speedfreeks bellow band
    By homebrew in forum 4-Tec Performance
    Replies: 20
    Last Post: 07-06-2011, 01:24 PM
  3. FS Speedfreeks Bellow Band - New $60 Shipped
    By tron in forum Sea Doo Classifieds
    Replies: 4
    Last Post: 06-23-2011, 05:50 PM
  4. speedfreeks bellow band
    By PHONE BOY2369 in forum 4-Tec Performance
    Replies: 32
    Last Post: 06-21-2011, 10:15 AM
  5. Carbon seal with bellow band install?
    By rmk82nd in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-04-2011, 10:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •