Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    TheEngineer's Avatar
    Join Date
    Aug 2007
    Location
    Tampa, FL
    Posts
    934
    +1
    131

    RXP-X 260 about 1 mph slower than the rest.

    My P-X has 114 hours on it. In bone stock form, with a brand new OEM IC, it runs a solid 1mph slower than other stock P-X's. This might not sound like much, but in a WOT distance race, it's a huge deal. The only thing not stock was the impellar boot. I rode last race in fresh water with no impellar boot on. However, I had heard that some of the drag racers purposely don't use these. Could that have been the cause of drag?


  2. #2
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Are you overweight? Lol

  3. #3
    TheElite0ne's Avatar
    Join Date
    Jan 2009
    Location
    Tampa, FL
    Posts
    383
    +1
    20
    Quote Originally Posted by Ocman View Post
    Are you overweight? Lol
    yea, he's a super fatty.

    When was the last time you replaced the wear ring? What prop and pitch? What RPM?

  4. #4
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,037
    +1
    672
    Engine alignment is a killer

  5. #5
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by TheEngineer View Post
    My P-X has 114 hours on it. In bone stock form, with a brand new OEM IC, it runs a solid 1mph slower than other stock P-X's. This might not sound like much, but in a WOT distance race, it's a huge deal. The only thing not stock was the impellar boot. I rode last race in fresh water with no impellar boot on. However, I had heard that some of the drag racers purposely don't use these. Could that have been the cause of drag?
    What rpms are you seeing?
    As with any skis, sometimes others are a little faster or slower than others. If you are seeing the right rpms, then it is probably something to do with the hull.

  6. #6
    What is the MPH showing on the dash and what RPM are you showing on the tach?

    My gauge reads right at 68 and the tach hangs right at 8060. It happens that the real throttle position is hanging right at 60% as I recall. If the prop / wear ring has issues, these numbers will not match.

    Andy

  7. #7
    TheEngineer's Avatar
    Join Date
    Aug 2007
    Location
    Tampa, FL
    Posts
    934
    +1
    131
    Wear ring is brand new. Prop has normal wear for a prop at 114 hours, but nothing serious. My ski's speedo has always stuck at 67 WOT (in stock) with an RPM of about 8020. RPMs will go a light bit higher when initially coming up to speed but then always back down to 8020.

    Prop is stock.

  8. #8
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Quote Originally Posted by TheEngineer View Post
    Wear ring is brand new. Prop has normal wear for a prop at 114 hours, but nothing serious. My ski's speedo has always stuck at 67 WOT (in stock) with an RPM of about 8020. RPMs will go a light bit higher when initially coming up to speed but then always back down to 8020.

    Prop is stock.
    Sure that's the same rpm the other skis are running. Should be a bit more?

  9. #9
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by TheEngineer View Post
    Wear ring is brand new. Prop has normal wear for a prop at 114 hours, but nothing serious. My ski's speedo has always stuck at 67 WOT (in stock) with an RPM of about 8020. RPMs will go a light bit higher when initially coming up to speed but then always back down to 8020.

    Prop is stock.
    Thats about right for stock rpms. They run 8040 ish.
    Get a straight edge and check you ride plate angle.

  10. #10
    These hulls are not real straight. I wonder if your buddy's is a little straighter than yours?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1 eninge rev's slower than the other
    By Pwgsx in forum Sea Doo Sport Boats
    Replies: 10
    Last Post: 08-04-2014, 10:45 AM
  2. thinking about getting a 2012 rxp-x 260
    By pwcbabe in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-08-2012, 12:56 AM
  3. Replies: 3
    Last Post: 06-18-2012, 03:52 AM
  4. Question about riva SCOM on european RXP X 260 2012
    By steffi69 in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-30-2012, 07:40 AM
  5. SeaDoo Rxp x 260. Few question about the pwc and performance.
    By Hunvaakaren in forum 4-Tec Performance
    Replies: 25
    Last Post: 05-19-2012, 10:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •