Results 1 to 4 of 4
  1. #1

    2003 Genesis 1200 DI - Running Issues after starter Bendix replacement

    Replaced the starter Bendix on my 2003 genesis I after replacing the jet pump housing due to jammed impeller. The jammed impeller took out a few teeth on the Bendix starter gear, not the flywheel gear. Pulled Flywheel to remove/replace the Bendix and noticed the two of the six magnets had a little damage thought might be due to debris from broken gear on Bendix, cleaned up inside flywheel and around stator and re-assembled. The ski barely starts and runs for a few seconds but no throttle control, stalls out in 10 to 15 seconds. won't start up right away again but will if I wait several minutes but again starts races and stalls out with no throttle control. CPS sensor checks out OK for static resistance but on stator coil winding pins 2 to 11 individual pins measure short to Gnd but OK ohms between the two pins. Could this be causing start/run issue with no throttle control?? Can the 12 magnet flywheel replacement be used on this 2003 Genesis without complete EMM reprogramming? Appreciate any help as usual, I've found this forum awesome for a couple of other issue. Thanks


  2. #2
    I'm addicted to Polaris PWC ghostinstallations's Avatar
    Join Date
    Aug 2011
    Location
    Rochester, New York
    Posts
    920
    +1
    28
    Yes, the 12 magnet flywheel can be installed without any programming. You may need to take it apart to see if any wires got damaged/pinched upon reinstall.

  3. #3
    Are you saying to check the stator wiring that I now have?? Since one winding is reading short to ground on both pins there must be a impinged wire somewhere? I checked the AC volts on all pins and they meet spec but this measurement is done while not connected to the EMM so a Gnd may not cause a problem until connected into EMM?? Does that sound right? Also used an o-scope to look at CPS signal and not sure if it's doing what it should. waveform is pseudo sine wave in bursts Peak to peak voltage about 4 Volts. the burst of sine waves seems to have a small peak as the engine is cranking. Isn't this supposed to give a pulse at TDC or close to the crank position at TDC?? Trying to figure out if these anomalies would cause the starting/ running and no throttle control??

  4. #4
    I'm addicted to Polaris PWC ghostinstallations's Avatar
    Join Date
    Aug 2011
    Location
    Rochester, New York
    Posts
    920
    +1
    28
    I believe the CPS is a magnetic pickup, so it will likely be a sine wave with a odd waveform. If you have a short to ground, then you have a pinched wire or damaged coil on the stator.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS Parting out my 2002 Genesis 1200 DI
    By vxrpete8 in forum Polaris Classifieds
    Replies: 84
    Last Post: 07-17-2015, 11:09 PM
  2. Polaris 800 di and polaris 1200 di running issues
    By jetskigreg in forum Polaris Open Discussion
    Replies: 3
    Last Post: 08-17-2011, 11:59 AM
  3. '02 genesis 1200 DI - Oil Pump
    By adamzpop in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 06-13-2010, 08:29 AM
  4. FS Polaris cover for Genesis 1200 DI
    By vxrpete8 in forum Polaris Classifieds
    Replies: 6
    Last Post: 10-06-2009, 02:57 AM
  5. Genesis 1200 di pump chattering bad help!!
    By Rebcammaz in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 05-05-2009, 04:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •