Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    Help!!!! Need advice on 2011 vxs

    Hello All,
    Bought a 2011 VXS new 2 yrs ago, have 54hrs on it (mostly hard)-
    I have put a RD cold air intake and RD high flow exhaust mod to let the engine breath better, we also installed a RIVA engine breather kit as well- just some basic mods-

    Ever since we installed the upgrades, seems like the engine isn't quite as fast, we've GPS'd it at 63-64mph on perfectly still cold water, we have been using 91 octane fuel, I don't know if that could be an issue?

    AND

    We wrecked our stock impeller, and installed a SOLAS impeller a few weeks ago, ever since the install, I feel a vibration (and hear a almost a rubbing sound) when cornering hard... just started after we installed the new impeller..... could I have installed it incorrectly? It seems to be working fine otherwise, no rubbing or vibration when running straight away...

    Has anyone any insight into these issues?

    Thanks,

    Josh


  2. #2
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    63-64 is about right for a top speed.

    As far as the vibration there is something wrong in your install.
    It needs to be checked before you have major issues.
    If that impeller comes loose it can do thousands in damage.
    I've seen a ski that needed a new motor because the impeller came loose.
    Have a professional do it if you can't find the vibrating part yourself.

  3. #3
    big john's Avatar
    Join Date
    Sep 2010
    Location
    Cocoa Beach, Florida, United States
    Posts
    3,395
    +1
    598
    67-68 should be capable right out of the box, what pitch impeller did you put in ???? you need to check to see whats its rubbing as well, maybe have someone familiar with the VXS platform look at it. where are you located ??

  4. +1 by:


  5. #4
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Big john knows his vxr skis.
    Your in great hands!!!

  6. #5
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    Quote Originally Posted by wotxxxsd View Post
    63-64 is about right for a top speed.

    As far as the vibration there is something wrong in your install.
    It needs to be checked before you have major issues.
    If that impeller comes loose it can do thousands in damage.
    I've seen a ski that needed a new motor because the impeller came loose.
    Have a professional do it if you can't find the vibrating part yourself.
    Dude ,
    Why do you have to post in every section when you have no clue as to the ski in question? I see you do this in every section of the Forum....you trying to get your post count up or something?

  7. #6
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    I've only had 5-6 vxr and vxs skis.
    The fastest was 66.7 gps speeds on a cool day.

    So I ride 100+ skis a year...
    Sorry I'm not perfect just having some fun...

    Your panties a little tight aquaholic??

  8. #7
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    You put out bad information to people that come here looking for correct information........If you dont know dont make up some shit...you having fun and giving out inaccurate information is not good for the Forum, or people trying to figure out a problem with their ski........read some of your previous post....nothing useful in them at all.....

  9. #8
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Yep that's me useless info..

    You figured me out.
    I'm just trying to up my post count...
    Wow I thought I had you fooled.
    Lmfao..

  10. #9
    Thanks for the advice, BUT I don't feel "vibration" per say.... only when cornering hard will I feel (what I think to be) almost a rubbing in the body of the PWC, not in the handle bars....

    I don't know how to describe it, its not a wobbling or shaking, almost a rubbing but only when cornering hard.... Had the same thing on a VX I rented when on vacation in Antigua last year, it had over 400hrs on it...

    It only started after we put the new impeller in...
    I'm located in Canada, we ride on the Ottawa River..... nice place, very quiet, and water is generally 80-85




    weird....

  11. #10
    big john's Avatar
    Join Date
    Sep 2010
    Location
    Cocoa Beach, Florida, United States
    Posts
    3,395
    +1
    598
    i don't think your hearing a rubbing, these VX series really scrub off speed when you turn, even slightly, your probably just hearing the motor pull down in rpms, its even worse with a aftermarket impeller ??? more then likely there is nothing wrong

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need advice on a VX cruiser
    By carbon in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 02-19-2016, 08:37 PM
  2. Help please! Need advice on 2006 rxt free flow
    By lukeybb in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-12-2013, 06:22 AM
  3. Need advice on engine repair, please help!
    By iolaus in forum 4-Tec Performance
    Replies: 41
    Last Post: 07-16-2008, 10:31 PM
  4. Need advice on pump cone..please help!
    By SeaDoocer in forum 4-Tec Performance
    Replies: 8
    Last Post: 12-11-2006, 01:23 AM
  5. Need advice on selling my ski overseas?
    By Shibby1485 in forum Sea Doo Open Discussion
    Replies: 26
    Last Post: 11-27-2005, 09:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •