Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    Water leaking into hull ....

    I finally got my 2005 r12x finished. had the motor out for a complete overhaul and new turbo. She runs great now. But it is taking on water.

    It doesn't leak anywhere inside when running on a hose. It only leaks in the water.

    I filled the ski up with water a little bit with the plugs in. I can see it leaking from both sides where the pump meets the rear of the hull on the outside.

    I was going to take this off, but I am trying to figure out where the lower bolts are that go into the hull.

    Is this leak a common problem?

    thanks for any input, I just want to ride it instead of fix it all the time lol.


  2. #2
    Waveblaster's Avatar
    Join Date
    Aug 2010
    Location
    St Augustine / Fl
    Posts
    99
    +1
    2
    Quote Originally Posted by shwine617 View Post
    I finally got my 2005 r12x finished. had the motor out for a complete overhaul and new turbo. She runs great now. But it is taking on water.

    It doesn't leak anywhere inside when running on a hose. It only leaks in the water.

    I filled the ski up with water a little bit with the plugs in. I can see it leaking from both sides where the pump meets the rear of the hull on the outside.

    I was going to take this off, but I am trying to figure out where the lower bolts are that go into the hull.

    Is this leak a common problem?

    thanks for any input, I just want to ride it instead of fix it all the time lol.
    Check the billets where the cables to the steering, reverse and if you have trim comes through the hull to the back. Honda uses a plastic billet that will fail and take on water. If that's the case then go to ebay there is a guy who sells aluminum billets which will last. I just ordered some for my F12X already did the r12. If not then check flush valve it's supposed to be a one way valve but sometimes fails too. I think its the first, JR let me know about that one....

  3. #3
    Thanks for the quick reply. I remember reading about those cracking and I looked there first. Would they leak right around the cable itself? I don't think it's the check valve because it leaks when filled inside with a hose too.

  4. #4
    I pulled the pump out and took a picture where is is leaking. It looks like it is coming from behind that housing
    Click image for larger version. 

Name:	IMG_20130724_103807_273.jpg 
Views:	67 
Size:	60.8 KB 
ID:	307823
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_20130724_103807_273.jpg 
Views:	59 
Size:	59.5 KB 
ID:	307822  

  5. #5
    I took a video too.


  6. #6

    Join Date
    May 2013
    Location
    Northern Ireland
    Posts
    82
    +1
    6
    so its leaking from the pump housing

  7. #7
    jlfx car audio's Avatar
    Join Date
    Jul 2011
    Location
    jackson, TN
    Posts
    534
    +1
    26
    Looks as tho its coming from transom plate . hopefully theirs not a hull crack . looks like u need to pull ride plate and transom . I want to think the bolts r from the inside on the bottom but could be wrong

  8. #8
    Well it was definitely coming from the transom plate. Man that thing was a pita to get off! Had to use a slide hammer and some ingenuity. So here is where I am at, you can see a spot in the fiberglass is thin or something. What do you think I should to do seal it back up so it won't leak again? I guess I'll start by removing the old sealer. I can tell someone had this plate off once before, but I am not sure why.

    Click image for larger version. 

Name:	IMG_20130724_144320_567.jpg 
Views:	57 
Size:	79.6 KB 
ID:	307857Click image for larger version. 

Name:	IMG_20130724_144509_869.jpg 
Views:	56 
Size:	46.9 KB 
ID:	307858Click image for larger version. 

Name:	IMG_20130724_144517_648.jpg 
Views:	58 
Size:	80.8 KB 
ID:	307859

  9. #9
    Well it looks like someone did some repairs to the tunnel at some point. the ride plate and intake grate weren't even glued on. I am going to clean everything really good and see if it needs further repair. I am also going to take out the 1,3,5 bar of the intake grate while I have it off. I can't win with this thing. lolClick image for larger version. 

Name:	IMG_20130724_154555_494.jpg 
Views:	74 
Size:	71.5 KB 
ID:	307863Click image for larger version. 

Name:	IMG_20130724_154600_748.jpg 
Views:	66 
Size:	58.3 KB 
ID:	307864Click image for larger version. 

Name:	IMG_20130724_154607_361.jpg 
Views:	71 
Size:	43.1 KB 
ID:	307865Click image for larger version. 

Name:	IMG_20130724_154611_205.jpg 
Views:	71 
Size:	82.1 KB 
ID:	307866Click image for larger version. 

Name:	IMG_20130724_154615_838.jpg 
Views:	80 
Size:	40.6 KB 
ID:	307867

  10. #10
    Waveblaster's Avatar
    Join Date
    Aug 2010
    Location
    St Augustine / Fl
    Posts
    99
    +1
    2
    Quote Originally Posted by shwine617 View Post
    Well it looks like someone did some repairs to the tunnel at some point. the ride plate and intake grate weren't even glued on. I am going to clean everything really good and see if it needs further repair. I am also going to take out the 1,3,5 bar of the intake grate while I have it off. I can't win with this thing. lolClick image for larger version. 

Name:	IMG_20130724_154555_494.jpg 
Views:	74 
Size:	71.5 KB 
ID:	307863Click image for larger version. 

Name:	IMG_20130724_154600_748.jpg 
Views:	66 
Size:	58.3 KB 
ID:	307864Click image for larger version. 

Name:	IMG_20130724_154607_361.jpg 
Views:	71 
Size:	43.1 KB 
ID:	307865Click image for larger version. 

Name:	IMG_20130724_154611_205.jpg 
Views:	71 
Size:	82.1 KB 
ID:	307866Click image for larger version. 

Name:	IMG_20130724_154615_838.jpg 
Views:	80 
Size:	40.6 KB 
ID:	307867
    Since your at this stage replace the billets you will be glad you did

  11. +1 by:


Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FXHO Water Leaking into Hull...symptom check please
    By macGruber in forum Yamaha PWC Performance (4-stroke)
    Replies: 7
    Last Post: 09-08-2015, 06:02 AM
  2. STX 1100 water leaking into hull. (Not from the hull seal)
    By 1650bullet in forum Kawasaki PWC Performance (2-stroke)
    Replies: 2
    Last Post: 05-07-2015, 07:51 AM
  3. 1100 stx water leaks into hull
    By waxsworth in forum Kawasaki PWC Performance (2-stroke)
    Replies: 1
    Last Post: 07-08-2014, 08:14 AM
  4. Water Leaking Into Hull
    By Bertramfegg in forum 2-Stroke Performance
    Replies: 14
    Last Post: 03-24-2013, 10:40 AM
  5. 2011 vxr water leaking into hull
    By yamalove in forum Yamaha PWC Performance (4-stroke)
    Replies: 7
    Last Post: 11-04-2011, 12:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •