Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 27
  1. #1

    Unhappy seat rubbing paint off down to the fiberglass

    I have a 2013 Sea Doo it has a whole 20 hrs on it. The seat has rub the paint off down to the fiberglass in 4 places under the seat and now it been sitting at the dealer waiting to get repaired for about a week now. They don't know or they won't give me a time when it will be ready. I'm getting the run around from the dealer on what causing the problem. They say it how I put the seat on and that not true. There only one way to put it on in the first place and then say the seat loose and it not at all loose. I think it the pastic ribits that is causing the problem or the metal stables. Has anyone else had this problem?


  2. #2
    Q in Arizona's Avatar
    Join Date
    May 2013
    Location
    Phoenix, Az
    Posts
    30,576
    +1
    7,356
    Yep...*sigh*

    Right side:
    Click image for larger version. 

Name:	IMAG3113_zps4a93f2fc.jpg 
Views:	159 
Size:	48.7 KB 
ID:	307874

    Left Side:
    Click image for larger version. 

Name:	IMAG3109_zps2d11ce92.jpg 
Views:	145 
Size:	43.1 KB 
ID:	307875

  3. #3
    ride it like you stole it!!! raceneked's Avatar
    Join Date
    Sep 2011
    Location
    Lake Havasu, AZ
    Posts
    3,021
    +1
    840
    i think it pretty much happens to all of them; well, at least the skis i've seen...

  4. #4
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    What ski do you have??? You might be waiting a while...........

  5. #5

    Join Date
    Oct 2012
    Location
    Australia
    Posts
    100
    +1
    7
    My seat is very tight to put on has 50h and no ware marks at all I would say your seat is loose enabling it to slide back and forth a few mm scratching off the paint

  6. #6
    jeteffect's Avatar
    Join Date
    Feb 2011
    Location
    Canada
    Posts
    374
    +1
    11

  7. #7
    Michigan sn-95's Avatar
    Join Date
    Sep 2010
    Location
    Hamilton MI
    Posts
    734
    +1
    32
    Yup, I have it too. Same exact spots. Only 11 hrs. on it.

  8. #8
    ride it like you stole it!!! raceneked's Avatar
    Join Date
    Sep 2011
    Location
    Lake Havasu, AZ
    Posts
    3,021
    +1
    840
    try a piece of felt applied to the bottom of the seat frame, or to the hull @ rub spots.

    ...at least no one can see it when you're riding.

  9. #9
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    My 12 RXPX does it, but has only rubbed off the warning stickers under the seat so far....

  10. #10
    jeteffect's Avatar
    Join Date
    Feb 2011
    Location
    Canada
    Posts
    374
    +1
    11
    Noticed a slight amount of rubbing on the starboard side of my GTI 2011 - but not through the gelcoat at this stage. I only noticed it because I seen this post and went looking for it.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Down to the wire, time to tune it up on the water.
    By ltmark in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 06-24-2012, 10:44 AM
  2. Replies: 2
    Last Post: 06-24-2011, 01:20 PM
  3. memorial day weekend! we are taking the RXP's down to the Gulf!
    By wisconsin_quat in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-11-2009, 12:59 PM
  4. Down to the last details
    By 97GPSLEEPER in forum Yamaha Old School Skis
    Replies: 24
    Last Post: 04-19-2008, 07:51 AM
  5. I Went Down To the Local Dealership. Holy Cow!!!
    By ccassone in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 04-20-2006, 07:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •