Results 1 to 4 of 4
  1. #1

    Join Date
    Jul 2011
    Location
    Northern California
    Posts
    218

    triple outlet pump installation question

    I have a 95 sL 750 and I installed a triple outlet pump among other things anyway It seems to be bogging and wont go over 10 mph. Im thinking I need to adjust the carbs cause I did not when I installed the triple outlet pump. Mag plug is turning black, cen one looks clean and wet, PTO is black and dry. Is that normal to have to adjust carbs after you install the pump?


  2. #2
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Typically it is not required to adjust the carbs when you install the pump. However, it is typically necessary to rebuild the carbs on this old of a ski......

    You can try resetting your needles to factory, but the fuel system, including the carbs, needs to be in top shape for things to operate properly....

    Turns Out from lightly seated:

    Highs
    Mag 1
    Cen 1/2
    PTO 3/4

    Lows 1/2

  3. #3

    Join Date
    Jul 2011
    Location
    Northern California
    Posts
    218
    So your talking high needles and Im guessing there are 3 low needles, Is factory setting considered rich in your opinion? Turn screws all the way in and bring them out number of turns to spec. you mentioned above right? Again Cris your coming through with the information Thanks. BTW if I need to rebuild where can I get the kit and instructions? Is it hard to do?

  4. #4
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Slowly turn screws all the way in until they are lightly seated or closed. John Zigler at watcon.com has the most complete rebuild kit available. Will set you back around $165 or so, but well worth it. The instructions are pretty straight forward. Take them apart, put the back together, replace the parts in the kit...... (basically)....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. triple outlet pump install question
    By Hurban96 in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 09-10-2009, 07:41 PM
  2. Help with triple outlet pump installation
    By skoots in forum Polaris Open Discussion
    Replies: 92
    Last Post: 08-11-2008, 02:10 PM
  3. Silly triple outlet pump Q
    By xlint89 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-27-2007, 11:55 PM
  4. oil pump install question
    By r33pwrd in forum Yamaha How To & FAQs
    Replies: 3
    Last Post: 06-25-2007, 04:07 AM
  5. Pump install question.
    By Mark S in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-01-2005, 09:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •