Results 1 to 3 of 3
  1. #1

    Join Date
    Feb 2012
    Location
    Coshocton,OH
    Posts
    52

    need help 640 tigershark

    it has 150psi both cylinders, checked reeds with scope look to be ok, took carb apart and cleaned looked to be ok also, starts up and idols, but as you take off it begins to miss and never cleans out, it acts very rich , fuel screws are about 1 1/4 out each, plugs are wet, could it be cdi ???


  2. #2

    Join Date
    Feb 2012
    Location
    Coshocton,OH
    Posts
    52
    it does have a small battery in it could that be the problem ???
    Quote Originally Posted by Rex Racing View Post
    it has 150psi both cylinders, checked reeds with scope look to be ok, took carb apart and cleaned looked to be ok also, starts up and idols, but as you take off it begins to miss and never cleans out, it acts very rich , fuel screws are about 1 1/4 out each, plugs are wet, could it be cdi ???

  3. #3
    Skoog's Avatar
    Join Date
    Aug 2013
    Location
    85 miles West of DFW South enterance 76462
    Posts
    68
    Get a clamp-on timing light and verify spark on both plugs. Never unplug spark plug lead without using a grounded plug to check the the spark. The high voltage coils can be permanently damaged since the electrical energy in the coil has no place to dissipate and can short out coil windings. I checked my shop manual and the CDI unit and there was no mention of a battery. Check your auto mix pump setting it may be delivering too much oil at low and medium speeds. It could also be your vacuum operated fuel pump isn't delivering the correct flow at higher speeds. Tackle one item at a time look for loose fuel hoses and vacuum leaks. Things like fuel tank strainer clogged and be thankful you engine mechanical is in good shape. Ed

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help 94 tigershark 640
    By Asmarine in forum Tigershark
    Replies: 3
    Last Post: 08-29-2012, 10:08 PM
  2. 97 tigershark monte carlo 1000 NEED HELP
    By zachrass06 in forum Tigershark
    Replies: 2
    Last Post: 07-06-2011, 11:48 AM
  3. NEED HELP URGENT(HULK) RXP DOWN
    By macattack in forum 4-Tec Performance
    Replies: 28
    Last Post: 11-22-2005, 02:39 PM
  4. I need help remove stock intercooler
    By orc in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-13-2005, 04:08 PM
  5. NEED HELP!!!!!
    By MartyRXP in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-10-2005, 08:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •