Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 26
  1. #1
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578

    Whats wrong with this picture????

    Let see if you guys can see what is wrong with this ski........If no one can figure it out I will post another pic...Click image for larger version. 

Name:	GTX 1.jpg 
Views:	414 
Size:	116.7 KB 
ID:	308143


  2. #2
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Quote Originally Posted by Tiny View Post
    Let see if you guys can see what is wrong with this ski........If no one can figure it out I will post another pic...Click image for larger version. 

Name:	GTX 1.jpg 
Views:	414 
Size:	116.7 KB 
ID:	308143
    No open loop cooling.

  3. #3
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    Nope. Not the problem...This ski had serious issues when it came in!!!!!

  4. #4
    iron head's Avatar
    Join Date
    Aug 2006
    Location
    ONT CANADA
    Posts
    616
    +1
    2
    water cool top valve and air cooled intercooler and exhaust

  5. +1 by:


  6. #5
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    wow water in the intake

  7. #6
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    The IC is plumbed into the air intake

  8. +1 by:


  9. #7
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    lol, didnt even notice at first. Dam.... Who did that work? lol

  10. +1 by:


  11. #8
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    did they blow it up? or only hydro lock

  12. #9
    Mothman's Avatar
    Join Date
    May 2011
    Location
    West Texas
    Posts
    2,999
    +1
    1,482
    Wow... I'm surprised it would run for more than 5 seconds in the water... Ouch.
    I bet they were wondering where the water was coming from...

  13. #10
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Hey.... at least you won't have to worry about blowing an IC and having it leak

    Bet the oil looked real nice in that thing!

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. whats wrong with this picture?
    By raceneked in forum Videos & Pictures
    Replies: 15
    Last Post: 04-29-2014, 01:07 PM
  2. Whats wrong with this picture
    By ncdoo in forum Yamaha Open Discussion
    Replies: 11
    Last Post: 05-29-2013, 07:38 PM
  3. Whats wrong with this picture
    By XLT Chad in forum Open Discussion
    Replies: 3
    Last Post: 05-04-2012, 05:04 PM
  4. whats wrong with this picture?
    By RHeller1 in forum Yamaha Open Discussion
    Replies: 12
    Last Post: 10-26-2009, 05:24 PM
  5. Whats wrong with this picture?
    By ou812 in forum 4-Tec Performance
    Replies: 20
    Last Post: 05-21-2007, 09:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •