Results 1 to 9 of 9
  1. #1

    Join Date
    Jul 2012
    Location
    Oklahoma
    Posts
    23
    +1
    4

    Need assistance!!!

    I took my 2010 ultra 260x out to the lake and there was no wind the water was like glass and the air temperature was 85 degrees. The watercraft has 100 hours I change the oil very frequently. I had a 1/2 tank of fuel the top speed I got on the GPS was 63.7 MPH. The engine seems to running good, but the RPMs seemed to be a little low (7500 RPMs), so I made sure the throttle was fully open and it was. I don't know what to do now please help. Thanks! The ski is all stock.


  2. #2
    brisyl's Avatar
    Join Date
    Feb 2009
    Location
    New Brunswick, Canada
    Posts
    681
    +1
    59
    check for air leak, be sure that all your clams are tight from the SC to IC and IC to the intake, be sure the sc belt is tight , have you ever clean the intercooler?

    Have you check your boost level when you were at top speed?

  3. +1 by:


  4. #3

    Join Date
    Jul 2012
    Location
    Oklahoma
    Posts
    23
    +1
    4
    I didn't find any leaks. All the clamps are tight. The supercharger belt is tight. No I have not cleaned the intercooler. The boost is a little past 10 PSI.

  5. #4
    brisyl's Avatar
    Join Date
    Feb 2009
    Location
    New Brunswick, Canada
    Posts
    681
    +1
    59
    It should be at 11,5psi, check your BOV at the back of the IC for leakage, they are prone to leak

  6. +1 by:


  7. #5
    the wotman likes boobs wotman's Avatar
    Join Date
    Mar 2009
    Location
    Australia
    Posts
    1,069
    +1
    48
    Is 85 hot?
    If so it may be nothing.
    Check the clear tube under air bix to see if the ic needs cleaning.

  8. #6
    brisyl's Avatar
    Join Date
    Feb 2009
    Location
    New Brunswick, Canada
    Posts
    681
    +1
    59
    30 celcius
    Quote Originally Posted by wot recession View Post
    Is 85 hot?
    If so it may be nothing.
    Check the clear tube under air bix to see if the ic needs cleaning.

  9. #7
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    doesnt really sound like you have a problem to me?

  10. #8
    brisyl's Avatar
    Join Date
    Feb 2009
    Location
    New Brunswick, Canada
    Posts
    681
    +1
    59
    you might be right, i didn't notice where he were from, Oklahoma is around 1000ft elevation and with a temp of 30 deg it can affect the performance quite a bit.

    Quote Originally Posted by nicjak View Post
    doesnt really sound like you have a problem to me?

  11. +1 by:


  12. #9
    UltraKvz's Avatar
    Join Date
    Feb 2011
    Location
    Earth
    Posts
    378
    +1
    23
    Quote Originally Posted by brisyl View Post
    you might be right, i didn't notice where he were from, Oklahoma is around 1000ft elevation and with a temp of 30 deg it can affect the performance quite a bit.

    Quote Originally Posted by nicjak View Post
    doesnt really sound like you have a problem to me?
    Yes, it sounds normal for a 260 at those conditions. If you want more you'll have to do plumbing, air and tweak the impeller and ONLY if you know what you are doing a pully aswell.

  13. +1 by:


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need assistance with performance
    By louch in forum Kawasaki PWC Performance (4-stroke)
    Replies: 10
    Last Post: 04-01-2009, 08:11 AM
  2. Ultra Breakdown- Need assistance, please.
    By Miss Ultra in forum Kawasaki Open Discussion
    Replies: 7
    Last Post: 06-21-2008, 12:39 AM
  3. Ultra Breakdown- Need assistance, please.
    By Miss Ultra in forum Kawasaki Open Discussion
    Replies: 4
    Last Post: 06-16-2008, 09:25 PM
  4. need assistance in lakeland/Winterhaven FL.
    By TLR in forum 4-Tec Performance
    Replies: 6
    Last Post: 02-14-2008, 03:12 PM
  5. My first winterization, need assistance....
    By jcc011185 in forum Polaris How To & FAQs
    Replies: 20
    Last Post: 09-06-2007, 07:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •