Results 1 to 2 of 2
  1. #1

    '92 WaveRunner will not start - power issues

    The ski starts right up and runs great when it has power. But power and ignition shuts on and off intermittently. I cleaned the switch assembly. It had some corrosion on the contacts inside the kill switch, but I still have the same problem now. It will come on sometimes then goes off again unexpectantly. Any suggestions?

  2. #2
    Connected contacts at solenoid. Started did turn over.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help with 1989 Waverunner 650 , will not start ...
    By cw_mi in forum Yamaha Old School Skis
    Replies: 10
    Last Post: 07-22-2014, 12:08 PM
  2. Newbie to the site...Waverunner will not start.
    By psmvchaser in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 05-31-2011, 06:31 AM
  3. Help! Polaris Waverunner will not start more than once a day....
    By polariscon in forum Polaris Open Discussion
    Replies: 8
    Last Post: 07-26-2010, 09:34 PM
  4. 2002 virage txi 1200 will not start/no power (electrical)
    By YZDOUGLAS in forum Polaris Open Discussion
    Replies: 14
    Last Post: 09-25-2009, 09:09 PM
  5. 650 WaveRunner will not start without starting fluid
    By GuateMan in forum Yamaha Old School Skis
    Replies: 2
    Last Post: 01-03-2008, 12:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts