Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    Join Date
    Jul 2009
    Location
    Uk
    Posts
    251

    Ultra 250x isc question

    Hi , can anyone tell me if a faulty isc give performance issues ?like poor top speed


  2. #2

    Join Date
    Jul 2009
    Location
    Uk
    Posts
    251
    Quote Originally Posted by ski33 View Post
    Hi , can anyone tell me if a faulty isc give performance issues ?like poor top speed
    Can anyone help me on this I have done countless searches and I get conflicting answers ?
    some say you can delete it and just turn idle up and it won't affect performance others say it will throw the tps range out and affect performance ?
    thanks in advance ski33

  3. #3
    Fat Man, Little Boat Region8Ultra250X's Avatar
    Join Date
    Jun 2007
    Location
    Jersey
    Posts
    5,563
    +1
    169
    if your having poor top speed, it could be related to bad plugs, belt tensions, a clogged intercooler, or a supercharger thats on its way out....

  4. #4

    Join Date
    Jul 2009
    Location
    Uk
    Posts
    251

    Quote Originally Posted by Region8Ultra250X View Post
    if your having poor top speed, it could be related to bad plugs, belt tensions, a clogged intercooler, or a supercharger thats on its way out....
    Cleaned ic also changed ic boost is good prop is brand new new plugs changed temp sensor brand new belt valve clearance is good also compression is good but GPS its doing 58.2 mph
    sorry should have posted it :/ the only thing that I can find at fault on the ski is the idle speed control valve do not cycle and ski cuts out when you let off quick.

  5. #5
    Fat Man, Little Boat Region8Ultra250X's Avatar
    Join Date
    Jun 2007
    Location
    Jersey
    Posts
    5,563
    +1
    169
    did you check belt tension? regardless of whether or not it was a new belt if you didnt adjust the tension properly you'd be done on speed.

  6. #6

    Join Date
    Jul 2009
    Location
    Uk
    Posts
    251
    Quote Originally Posted by Region8Ultra250X View Post
    did you check belt tension? regardless of whether or not it was a new belt if you didnt adjust the tension properly you'd be done on speed.
    Yea checked it mate its all good. It's either the isc or its new supercharger time

  7. #7
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,157
    +1
    598
    Quote Originally Posted by ski33 View Post
    Hi , can anyone tell me if a faulty isc give performance issues ?like poor top speed
    ISC Will not affect performance . Its job in life is IDLE control , nothing else

    Waz

  8. #8
    Quote Originally Posted by ski33 View Post
    ...ski cuts out when you let off quick.
    My friend had 09 LX that started doing this. Ski accelerated normally but when you let off throttle engine would die right away. Dealer said it was a valve problem possibly caused by inferior gas (ethanol?). Partial rebuild required but ski has run great ever since. It was not my ski so I did not personally investigate beyond riding ski and confirming the problem and then the fix.

  9. #9

    Join Date
    Jul 2009
    Location
    Uk
    Posts
    251
    Quote Originally Posted by sirbreaksalot View Post
    Quote Originally Posted by ski33 View Post
    Hi , can anyone tell me if a faulty isc give performance issues ?like poor top speed
    ISC Will not affect performance . Its job in life is IDLE control , nothing else

    Waz
    thanks Waz .I think the isc is toast though it shows good resistance as per manual but don't cycle.
    I suspect another issue and been reading other threads and I think I'll GPS it with seat off to see if its leaking exhaust fumes and ill replace all gaskets first.
    Thanks again everyone for your help. Cheers

  10. #10

    Join Date
    Jul 2009
    Location
    Uk
    Posts
    251
    Quote Originally Posted by Blue 182 View Post
    Quote Originally Posted by ski33 View Post
    ...ski cuts out when you let off quick.
    My friend had 09 LX that started doing this. Ski accelerated normally but when you let off throttle engine would die right away. Dealer said it was a valve problem possibly caused by inferior gas (ethanol?). Partial rebuild required but ski has run great ever since. It was not my ski so I did not personally investigate beyond riding ski and confirming the problem and then the fix.
    Thanks for the reply .
    ski was rebuilt at 47 hrs (99 hrs now)becouse of pump failure that affected bottom end , it was rebuilt and 260 piston were used also valve clearance is good and compression also good all this was done by the guy that had it before me it was 69.7 on GPS before I owned it but I've never recorded any speeds like this. The strange thing is rpms are around 7760 there's no cavitation and prop is new before I changed prop rpm was around same I use 98ron gas

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ultra 250x Rebuild questions
    By skeletonbobo in forum Kawasaki How To & FAQs
    Replies: 7
    Last Post: 11-14-2016, 09:04 AM
  2. 07 ultra 250x hesitation question
    By Jessie00721 in forum Kawasaki Open Discussion
    Replies: 30
    Last Post: 08-09-2012, 11:53 AM
  3. Ultra 250x muffler question?
    By XRIDER in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 04-13-2007, 08:41 AM
  4. question on wedge ring bolts for Ultra 250x
    By XRIDER in forum Kawasaki PWC Performance (4-stroke)
    Replies: 2
    Last Post: 03-26-2007, 05:46 PM
  5. couple quick Ultra 250x questions
    By cue03 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 27
    Last Post: 02-11-2007, 02:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •