Results 1 to 9 of 9
  1. #1

    Low Oil Pressure P1520

    Guys,

    I completed a rebuild on a 2006 RXP this spring. I started getting the low oil pressure alarm. I replaced both sensors with no change. I then hooked up a gauge and found the alarm was real. When the alarm comes in, the actual oil pressure is below 10 psi. Thus, I replaced the oil pressure regulator. I am still getting the same error. I am now wondering if I installed the right part. The regulator I took out had one spring. The new one had two which is what I installed. Should I take out the smaller spring? I was careful not to over torque it. Any other ideas what could be causing it.


  2. #2
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    are u using the same block, and rocker shaft?
    Did u put the main bearings on the correct halves of the block? there are 2 diff ones for the Main bearings

  3. #3
    Roll Tide!! SeadooTech's Avatar
    Join Date
    Jun 2011
    Location
    Birmingham, AL
    Posts
    662
    +1
    18
    How many hours have you put ont he ski and the 2 spring is the new superseded part. Also I would double check the torque on the regualtor to make sure you didn't squish the cage that will cause the piston to stick and create no oil pressure. What did the old regulator look like?

  4. #4
    The ski has less than 2 hours since the rebuild. I replaced the bearings, but I am sure I was not looking at which bearing went where. I bought SBT bearings and they looked identical. When I took the old regulator out, it looked fine and it was not stuck in the cage. Do I need to open the engine again?

  5. #5
    brl96. I would suggest that you go back and check your oil filter and make sure that it did not collapse. I had the same thing to happen after a long period of the ski being down. It can get clogged with sediment and high flow/pressure collapse.

    check out this thread. Hope this is the problem as this is the easiest fix of all.

    http://www.greenhulk.net/forums/showthread.php?t=199688

  6. #6
    Eastside Powersports Slow 91's Avatar
    Join Date
    Sep 2008
    Location
    River Crew CT
    Posts
    4,248
    +1
    544
    Quote Originally Posted by psycho rxp View Post
    are u using the same block, and rocker shaft?
    Did u put the main bearings on the correct halves of the block? there are 2 diff ones for the Main bearings
    you cannot mix up main bearings.

  7. #7
    I checked the filter. It looks good. Any other ideas?

  8. #8
    Eastside Powersports Slow 91's Avatar
    Join Date
    Sep 2008
    Location
    River Crew CT
    Posts
    4,248
    +1
    544
    if your oil pressure is low, I would start looking into main/rod bearing clearances.

  9. #9
    Thanks. I will pull the motor and check the clearances.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. P1520 low oil pressure on my 2007 rxt help
    By Robbie71067 in forum 4-Tec Performance
    Replies: 5
    Last Post: 09-03-2015, 07:31 AM
  2. 2003 GTX Limited low oil pressure
    By chuck2 in forum 4-Tec Performance
    Replies: 10
    Last Post: 09-20-2012, 12:35 PM
  3. problem low oil pressure light
    By thegasman34 in forum Honda Open Discussion
    Replies: 1
    Last Post: 04-27-2009, 06:45 PM
  4. low oil pressure warning/buzzer
    By zone 5 in forum 4-Tec Performance
    Replies: 2
    Last Post: 09-15-2008, 10:41 PM
  5. Low oil Pressure Sensor Threads
    By kc8lbn in forum Honda How To & FAQs
    Replies: 1
    Last Post: 03-12-2008, 08:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •