Results 1 to 5 of 5
  1. #1

    Join Date
    Jul 2013
    Location
    Ohio
    Posts
    2

    New to hulk 96 venture not performing help

    Hello I just bought my yamaha 1100 venture it was only doing 6x mph I changed the plugs then it got to 35 mph the next day it was back to 6 mphthe history off the ski. I was told it was a new motor, other looks it after the new motor it sat for 2 years, could the carbs be doing this and how fast do they go, thanks


  2. #2
    gp1200270's Avatar
    Join Date
    Jun 2013
    Location
    East Coast
    Posts
    46
    +1
    2
    Yeah most likely you should go through your carbs.When new motor was installed did they do this.You dont want to fry the motor and the carbs are a huge part.a few years ago I had a similar problem with my gp 1200.The carbs suposley were rebuilt.I took them apart and it look liked they were never touch.

  3. #3

    Join Date
    Jun 2012
    Location
    McCalla, Alabama, United States
    Posts
    46
    I agree, carbs are the first thing I would check. Having clean, well working carbs are critical to the performance of these skis.

  4. #4
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    2,773
    +1
    129
    You better also do a compression check.

  5. #5
    Quote Originally Posted by Nettles View Post
    Hello I just bought my yamaha 1100 venture it was only doing 6x mph I changed the plugs then it got to 35 mph the next day it was back to 6 mphthe history off the ski. I was told it was a new motor, other looks it after the new motor it sat for 2 years, could the carbs be doing this and how fast do they go, thanks
    If your digital display is working correctly, you should see 59 mph, tops.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help with new (to me) 96 SL780
    By brian_ks in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 06-17-2016, 02:53 PM
  2. New to the site... any info will help !!
    By Davis151 in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-01-2010, 06:36 PM
  3. New to me 96 Venture 1100
    By CaliCruiser in forum Yamaha Open Discussion
    Replies: 7
    Last Post: 06-28-2010, 12:01 AM
  4. new to me 96 Sltx 1050 issues
    By tediesel in forum Polaris Open Discussion
    Replies: 6
    Last Post: 07-16-2009, 06:30 PM
  5. new to the site, but not skis
    By willyandrew in forum Open Discussion
    Replies: 10
    Last Post: 06-16-2008, 10:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •