Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    1999-SLTX's Avatar
    Join Date
    Jul 2013
    Location
    phx,az
    Posts
    261
    +1
    2

    do these drive shaft ends look good ? thx

    hello - going thru the jet pump on my 99 sltx , I noticed I was missing one of the drive shaft bumper rubber ends the one on the end that goes into the engine coupler, but do these drive line ends look good still usable ? they seem fine but im new to ski's , I just put all new rubber on it ! thx for the help


    Click image for larger version. 

Name:	1.jpg 
Views:	114 
Size:	92.4 KB 
ID:	308530Attachment 308531Click image for larger version. 

Name:	3.jpg 
Views:	127 
Size:	104.9 KB 
ID:	308532Click image for larger version. 

Name:	4.jpg 
Views:	88 
Size:	90.6 KB 
ID:	308533Click image for larger version. 

Name:	5.jpg 
Views:	158 
Size:	97.4 KB 
ID:	308534Click image for larger version. 

Name:	r.jpg 
Views:	85 
Size:	133.0 KB 
ID:	308535


  2. #2
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Look OK to me...

  3. #3
    I'm addicted to Polaris PWC ghostinstallations's Avatar
    Join Date
    Aug 2011
    Location
    Rochester, New York
    Posts
    920
    +1
    28
    Its kinda toasted. It will still work, but if you decide to replace the coupler or impeller, you need to replace the shaft.

    Looks like you need to align the engine. Never seen so much engine side wear before!

  4. +1 by:


  5. #4
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Maybe it's the lighting...

  6. #5
    1999-SLTX's Avatar
    Join Date
    Jul 2013
    Location
    phx,az
    Posts
    261
    +1
    2
    ok what happen was I had a loud squeal sound from jet pump and no take off and then finally I could get it to take off and get back to shore, the coupler looked like it spun on itself ,

    so I bought a new engine rubber coupler, im having the impeller redid at impellpros now,

    there was one of the bumper ends missing could that cause anything ?

    I could get a pic of the end to help better figure out if the engine is miss aligned or if the end is really toasted? which end do u guys need to see better and what angle ? thanks for the help

  7. #6
    1999-SLTX's Avatar
    Join Date
    Jul 2013
    Location
    phx,az
    Posts
    261
    +1
    2
    also so if anything is out of spec the engine is lil more to one side then the other ?


    pic 3 of the ends lil mushroomed and looks maybe worn on one side ? is that from motor miss aligned ?

    I do have a new coupler and another good used coupler, which should I run with old shaft ?

    u think by looking at the shaft the impeller splines will be ok ?
    Last edited by 1999-SLTX; 07-29-2013 at 12:27 PM.

  8. #7
    I'm addicted to Polaris PWC ghostinstallations's Avatar
    Join Date
    Aug 2011
    Location
    Rochester, New York
    Posts
    920
    +1
    28
    The impeller side looked OK, not great. I would not destroy a replacement coupler with that shaft...get a new shaft and align the engine.

  9. #8
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    I agree with Ghost. Get a new shaft and align the motor.

  10. #9
    1999-SLTX's Avatar
    Join Date
    Jul 2013
    Location
    phx,az
    Posts
    261
    +1
    2
    anyone have a new or really good shape used drive shaft for sale cheap ? thx
    Last edited by 1999-SLTX; 07-29-2013 at 04:38 PM.

  11. #10
    1999-SLTX's Avatar
    Join Date
    Jul 2013
    Location
    phx,az
    Posts
    261
    +1
    2
    Quote Originally Posted by ghostinstallations View Post
    The impeller side looked OK, not great. I would not destroy a replacement coupler with that shaft...get a new shaft and align the engine.
    is there a trick or anything to know b4 I do it , ? I seen the post on here I think it was, plus I have the service manual here ,

    I see 2 part #'s for the shaft I read there is a new and old style ?

    old being 6230103 -

    new shaft 6230205 -

    if this is the case whats the difference ? does it matter which I buy I need it for a nujet impeller , do all shafts fit both style impellers skattrak and nujet ?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. S3 Rxtx drive shaft end float ???
    By SLASHER in forum 4-Tec Performance
    Replies: 17
    Last Post: 11-10-2014, 07:15 AM
  2. WTB - Parts Looking for RXP drive shaft (Good condition) 04'- 09'
    By psycho rxp in forum Sea Doo Classifieds
    Replies: 5
    Last Post: 05-14-2013, 12:28 PM
  3. RXP Drive Shaft End Plug gone?
    By skigolfnut in forum 4-Tec Performance
    Replies: 10
    Last Post: 11-08-2012, 07:28 PM
  4. How do I loosen the drive shaft for removal?
    By JAG in forum 4-Tec Performance
    Replies: 11
    Last Post: 10-28-2006, 11:08 AM
  5. How do these look after 26hrs?.......
    By peteshauling in forum Yamaha PWC Performance (2-stroke)
    Replies: 17
    Last Post: 08-13-2006, 08:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •