Results 1 to 4 of 4
  1. #1
    ben01251979's Avatar
    Join Date
    Jun 2013
    Location
    Portage, WI
    Posts
    143
    +1
    1

    slow to idle down

    I just got my emm back from dfi technology and my pwc runs now other than it is slow to idle down from reving up but when it idles down it does stay running. What would cause that? It has not been run since begging of last summer it does tho have new plugs and fresh gas that I put in it bout a month ago. It is a virage I 04 and the reason I'm am asking is because my 02 does not idle the same thanks in adv. Ben


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    I would suspect the TPS is going bad. You can swap TPS between the two machines and see if the symptom follows.

    Make sure you get the TPS spring positioned correctly and do not over tighten the TPS bolts.

  3. #3
    ben01251979's Avatar
    Join Date
    Jun 2013
    Location
    Portage, WI
    Posts
    143
    +1
    1
    will it hurt to run it with a bad tps

  4. #4
    ben01251979's Avatar
    Join Date
    Jun 2013
    Location
    Portage, WI
    Posts
    143
    +1
    1
    I switched the tps sensors from my good pwc to the one that has the problem and it took care of it so found one and am going to go get it tommarow so hopefully no more suprises after I put it in and thanks for the help k447

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 16
    Last Post: 07-31-2014, 06:20 AM
  2. 10 seconds at WOT and down to idle
    By dthm03 in forum Tigershark
    Replies: 2
    Last Post: 09-09-2013, 07:36 AM
  3. 2007 F12x - Is it possible to turn down the idle?
    By barmanvarn in forum Honda How To & FAQs
    Replies: 4
    Last Post: 11-23-2010, 12:14 PM
  4. 657x will not slow down to idle
    By gfmgp in forum 2-Stroke Performance
    Replies: 7
    Last Post: 06-26-2010, 09:00 PM
  5. MSX150 wont come back down to idle from WOT
    By Shibby1485 in forum MSX/Matrix
    Replies: 3
    Last Post: 08-18-2009, 11:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •