Results 1 to 5 of 5
  1. #1

    2001 XP cavitation

    I just replaced my impeller and wear ring. After 30 minutes of riding my machine died and would not crank. I towed it in and later that night it started up. The next time I put it in the water it started to cavitate and within 10 minutes it got very bad and the motor screams but the ski struggles to get up on plane. Once it does eventually get up on plane it starts to perform much better... I pulled the wear ring and impeller and the look fine... Motor is making power but not putting it to the ground..drive shaft related?
    Any suggestion?


  2. #2
    SURFnTURF's Avatar
    Join Date
    May 2007
    Location
    Australia
    Posts
    879
    +1
    11
    Did you install the NEOPRENE SEAL between the pump and shoe ?

    The engine stopping is a worry !! Did you find the reason why it stopped?

  3. #3
    PWC Addict lilman573's Avatar
    Join Date
    Feb 2010
    Location
    Central NJ
    Posts
    2,947
    +1
    207
    I had this problem once. Turned out to be the through hull fitting being cracked and sucking air into the pump from the engine compartment. I'd take a look and make sure it isnt cracked.

  4. #4
    Carbon seal is leaking. Its the little boot between the rear of the hull and the driveshaft. If your ski is in the water, pull back on the boot and you will see water come into the hull. That is how the boot operates, like a spring pushing forward on the steel shoulder on the driveshaft. It can wear out....not leak water but suck air from inside the hull. If it is not messed up or cracked, a temporary fix is to loosen the rear boot hoseclamp, push the boot forward a little bit (3/16") and re-tighten the hoseclamp. That puts more tension on the seal.
    Try this, with a little grease on the seal. If it helps, you found your problem. Remember.....temporary fix

  5. #5

    Join Date
    May 2013
    Location
    fargo nd
    Posts
    108
    +1
    1
    Quote Originally Posted by RIDEH2O View Post
    Carbon seal is leaking. Its the little boot between the rear of the hull and the driveshaft. If your ski is in the water, pull back on the boot and you will see water come into the hull. That is how the boot operates, like a spring pushing forward on the steel shoulder on the driveshaft. It can wear out....not leak water but suck air from inside the hull. If it is not messed up or cracked, a temporary fix is to loosen the rear boot hoseclamp, push the boot forward a little bit (3/16") and re-tighten the hoseclamp. That puts more tension on the seal.
    Try this, with a little grease on the seal. If it helps, you found your problem. Remember.....temporary fix
    This is cool to find. I may have the same problem. Revlimiter all day long untill low-midrange...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 XP cavitation issues after sharp turns
    By r4ma1r in forum 2-Stroke Performance
    Replies: 5
    Last Post: 05-28-2008, 06:29 PM
  2. 2001 XP Crank/Cases match on 2001 RX X Engine
    By jbracing in forum 2-Stroke Performance
    Replies: 2
    Last Post: 04-16-2008, 05:19 AM
  3. Speedo not working on 2001 XP
    By ingin69 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 01-06-2008, 01:30 PM
  4. 2001 XP
    By subseawellhead in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 09-14-2007, 04:16 PM
  5. 96 xp cavitates
    By rlt in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 05-11-2007, 07:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •