Results 1 to 6 of 6
  1. #1

    '04 F12X Starter / Main Relay

    Here's the problem:

    When I insert the key, the everything comes on and looks good. When I attempt to start the ski, I hear one distinct click, which I believe is coming from within the larger black (first picture, pictured w 6 screws removed). After all the research I've done on here I believe the Main Relay needs to be replaced(second picture, shown removed), however the part number of mine ends in 670, and everything I find online is 671 or 672. Am I heading in the right direction? And if so can I use one of the other parts numbers in place of the original?

    Thanks for all the help!
    Adam

    Click image for larger version. 

Name:	image (6).jpg 
Views:	87 
Size:	90.1 KB 
ID:	309234Click image for larger version. 

Name:	image (7).jpg 
Views:	82 
Size:	112.5 KB 
ID:	309235


  2. #2
    xdrian's Avatar
    Join Date
    Nov 2008
    Location
    Brisbane Australia
    Posts
    898
    +1
    225
    the one loud click coming from the large box is the start solenoid they can get burnt internal contact and connect voltage through but not pass high current.



    Quote Originally Posted by golferab05 View Post
    Here's the problem:

    When I insert the key, the everything comes on and looks good. When I attempt to start the ski, I hear one distinct click, which I believe is coming from within the larger black (first picture, pictured w 6 screws removed). After all the research I've done on here I believe the Main Relay needs to be replaced(second picture, shown removed), however the part number of mine ends in 670, and everything I find online is 671 or 672. Am I heading in the right direction? And if so can I use one of the other parts numbers in place of the original?

    Thanks for all the help!
    Adam

    Click image for larger version. 

Name:	image (6).jpg 
Views:	87 
Size:	90.1 KB 
ID:	309234Click image for larger version. 

Name:	image (7).jpg 
Views:	82 
Size:	112.5 KB 
ID:	309235

  3. #3

    Join Date
    Aug 2013
    Location
    Denver, NC
    Posts
    31
    +1
    1
    I bought a ski that had been sitting for years and made the same sound even after we replaced the relay. The pump had seized due to the wear ring swelling. Once we took the pump off it started right up. CC

  4. #4
    xdrian's Avatar
    Join Date
    Nov 2008
    Location
    Brisbane Australia
    Posts
    898
    +1
    225
    good news

  5. #5
    replaced the relay with no luck, going to try pulling the pump off like CC mentioned and see where that gets me...

  6. #6
    xdrian's Avatar
    Join Date
    Nov 2008
    Location
    Brisbane Australia
    Posts
    898
    +1
    225
    take the plugs out and wind over by hand this will prove that all ok not locked up pump assy

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 04 RXP Starter Relay replacement
    By hdzcar in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 06-27-2011, 02:36 PM
  2. 04 f12x issue
    By bigdeez in forum Honda Performance
    Replies: 5
    Last Post: 07-29-2009, 01:37 PM
  3. 04 F12x
    By rexzazo in forum Honda Skis
    Replies: 0
    Last Post: 10-26-2008, 07:43 PM
  4. 04 f12x max speed??
    By rexzazo in forum Honda Open Discussion
    Replies: 10
    Last Post: 10-12-2008, 09:54 PM
  5. OIl for 04 f12x
    By rexzazo in forum Honda Open Discussion
    Replies: 3
    Last Post: 10-09-2008, 12:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •