Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    maintenance light came on

    I have a 2011 seadoo Rxt-x and had all the updates done to the computer and today with 35 to 36 hours the maintenance light flashes on when the ski is started. I can't find anything in my manual that says maintenance for 35 hours but I do see a 25 hour check. My question is there a maintenance for 35 hours?? Or is there a problem with the computer?? help


  2. #2
    Also the ski is bone stock took it up to 70mph but when the ski had around 15 hours it was saying 71 to 72 now its pulling and once it hits 70 I can feel the ski pull back and then it goes between 69-70 is that normal is the limiter kicking in now?

  3. #3
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    It sounds like they didn't turn off the light when the oil change was done.
    They should have deleted that when you got it serviced.
    It's just a light and will not hurt anything.

  4. #4
    the light came on right at 10 hours but I didn't take it to the shop till 11 hours they did the oil change and the 10 hour maintenance and its been off since then until today when it hit 35 - 36 hours

  5. #5
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    I've sold a few low hour newer units that had the same light come on. Some as late as 45-48 hrs.
    Doesnt make since unless It's just another way seadoo gets you to return to the shop for you to spend more $$$..

  6. #6
    ok thanks just wasn't sure if I should spend the cash to have the light turned off I just thought maybe the computer had a bug. Also how many hours do you recommend to change plugs and what would you say top speed should be for a stock unit? Am I in the range just seems strange that I was seeing 71-72 and now its 69-70

  7. #7
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    I change plugs 1 time a year unless you foul a plug before then.

    I think your minor loss of speed is probably from heat soak. It's happening to every body this time of year with hot air and warm waters we are riding in.
    I wouldn't spend the $$ for the light. I know its annoying but its just light..

  8. #8
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    You are in the right range for speed.
    Are you going by the dash speed or gps??
    Dash speeds are always off some..

    Newer skis are usually 2-3 mph off and older skis I've seen 6-8 mph off..

  9. #9
    dash speed i'm going off. I probably should change the plugs I left them in there from last year. Also what of oil do you use for the motor I really don't want to buy the seadoo oil but I'm having a hard time finding the 10w40 semi synthetic oil in stores up here in Cleveland. Then when I winterized the ski I've read up that fogging oil is hard on the rings so I didn't bother using it but I did do everything else.

  10. #10
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    I use the Valveoline 10/40 motorcycle oil wet clutch formula. Pic of a motorcycle on the bottle. I've used it in all the s/c skis.
    In florida I don't winterize my ski. But I would fog the motor when you store it for months at a time. You don't want any rust to form on valves or pistons.. these are watercrafts that do have constant moisture around them.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Oil Warning Light came on... oil level was fine.
    By smbstyle in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 07-26-2009, 07:34 PM
  2. Oil Pressure light came on for a minute
    By MrSxy4Ever in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 06-17-2008, 02:25 PM
  3. Installed the Stage1 and my check enging light came on...
    By Denali44 in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 04-16-2006, 11:04 AM
  4. MAINTANCE LIGHT CAME ON AT 69 HRS
    By macattack in forum 4-Tec Performance
    Replies: 1
    Last Post: 09-02-2005, 08:24 AM
  5. check engine light came on when i went down to sea level
    By macattack in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-01-2005, 02:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •