Results 1 to 3 of 3
  1. #1

    Join Date
    Aug 2013

    Virage overheating

    We just bought a 02 virage 700. Took it out to the lake, went out for about five min and the overheat light came on. Checked under the seat and the exhaust was extremely hot. One of the guys at the lake said that the water pump is not working?? I don't know very much about pwc's any help would be appreciated

  2. #2
    Rasta Mon Condoms We Be Jammin!!!!! TxPro1200's Avatar
    Join Date
    Aug 2006
    check the nozzle screen inside the pump tail cone for obstruction

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    near Toronto, Canada

    Also remove and check the mesh water filter screen and orifice that feeds the exhaust pipe water injection.

    See my signature links for more info.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Virage I overheating
    By johnh in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-31-2013, 08:02 AM
  2. 2002 Polaris Virage TXI Overheating???
    By KMF in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 09-08-2010, 08:57 AM
  3. Overheating and loss of power on 2001 Virage TX
    By bruce0429 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-14-2009, 02:26 PM
  4. 2001 Virage TX overheating on hose
    By skiversinc in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 08-17-2008, 09:54 AM
  5. Overheating question
    By carlo4tech in forum 4-Tec Performance
    Replies: 1
    Last Post: 11-25-2005, 08:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts