Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1

    Join Date
    Jun 2013
    Location
    Bergen county, NJ
    Posts
    45

    1200 PV reving out of control.

    I just built a pover valve motor for my 2001 xlt. Parts included new crank, crank seals, new gaskets, pistons, and cylinders bored. When I start the ski it immediately revs to 6k and stays there. If I give it some throttle it will rev up more with no problem. From the research I did people were saying it may be a vacuum leak. I took the carbs off they look fine and I put gasket sealant on the intake gaskets to help seal. Still runs the same. Compression is around 115 lbs across the board. I'm running premix fuel. It has riva air filters/flame arresters. Any ideas?


  2. #2

    Join Date
    Apr 2010
    Location
    Greenville, NC
    Posts
    281
    +1
    4
    Did you pressure test the motor?

  3. #3

    Join Date
    Jun 2013
    Location
    Bergen county, NJ
    Posts
    45
    Quote Originally Posted by 992door View Post
    Did you pressure test the motor?
    I smoked it with a smoke machine. Didn't see any leaks

  4. #4
    mudslanger's Avatar
    Join Date
    Jul 2010
    Location
    Huntsville Al
    Posts
    1,326
    +1
    49
    What happens when you pull the choke. have you looked in the carbs to see if the throttle plates are closed. and did you rebuild the carbs and sinc the carbs.

  5. #5
    lukejaeger1's Avatar
    Join Date
    Jul 2011
    Location
    Iowa
    Posts
    181
    +1
    1
    This happened to me once and turned out my idle was out of adjustment. It sounds too simple but try checking that.

  6. #6

    Join Date
    Jun 2013
    Location
    Bergen county, NJ
    Posts
    45
    I opened up one of the carbs real fast. Everything looked ok. I turned the idle screw some with no effect.

  7. #7

    Join Date
    Jun 2013
    Location
    Bergen county, NJ
    Posts
    45
    Damn I feel like a rookie. Throttle cable was out of adjustment and didn't have any play. Seems to be running good. I'll run it on the hose trw to know for sure.

  8. #8
    lukejaeger1's Avatar
    Join Date
    Jul 2011
    Location
    Iowa
    Posts
    181
    +1
    1
    That's how I felt too. At least it was nothing major. Good luck!

  9. #9
    mudslanger's Avatar
    Join Date
    Jul 2010
    Location
    Huntsville Al
    Posts
    1,326
    +1
    49
    Glad to see its something simple.

  10. #10

    Join Date
    Jun 2013
    Location
    Bergen county, NJ
    Posts
    45
    Ran it on the hose today. It ran great so I figured I'd take it to the water. Started in the water and idled good. Went to take off and right before I got on plane it bogged out. And I hear a clicking coming from up front. I rode in a circle like this for about 5 minutes to try and get it to go with no luck. I don't think it's a fuel problem because it reacted identical every time. Got no better or worse. And like I said in the previous post I opened one of the carbs and it looked ok.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Seadoo over-revving out of control
    By RyanNZ in forum Sea Doo Open Discussion
    Replies: 18
    Last Post: 12-22-2010, 08:44 AM
  2. FS '98 1200 pv PART OUT!!!
    By joeg12345 in forum Yamaha Classifieds
    Replies: 9
    Last Post: 10-29-2009, 05:47 AM
  3. Out of control?
    By shawn alladio in forum High Performance Watercraft Safety
    Replies: 3
    Last Post: 07-24-2008, 12:55 PM
  4. Polaris 750 Engine Racing out of control
    By mkulczyckyj in forum Polaris How To & FAQs
    Replies: 24
    Last Post: 07-08-2007, 11:01 PM
  5. Who's Good With 95 Waveraider? Its out of Control!
    By ccassone in forum Yamaha Old School Skis
    Replies: 3
    Last Post: 07-05-2006, 07:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •