Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 38
  1. #1

    Burned up second Piston. 780 SLX

    Hey guys,
    Had issues with the ski this spring. Took it to get looked at. Turned out the PTO was at 0 PSI. Had all three carbes rebuilt and the piston redone. When I got it back it started normally, but soon (like less than a mile later) started shutting off. Then would start right back up again. Eventually I took it back to dock to find my PTO plug fouled with metal.

    So here is the question. If my carbs are good and I did not over heat or run out of oil. Is the fuel pump the next place to look? Could it have been the issue from the get go? In any case I am nervous about putting in another piston if the cause is still not determined.

    Thanks!


  2. #2
    David Drkvampire2001's Avatar
    Join Date
    Jul 2011
    Location
    Edgerton, Wisconsin, United States
    Posts
    2,857
    +1
    30
    YES very good chance it was your fuel pump, you need to give attention to the complete fuel system of these skis, that means rebuilding the carbs with GENUINE MIKUNI parts. Replacing all fuel lines, fuel selector, if equipped fuel filter, and MOST IMPORTANT upgrading to the triple outlet fuel pump could have possible been from an air leak by the carb gaskets. causing it to go lean. but im putting my money on fuel lines and fuel pump. did it burn a hole in the top of the piston?

  3. #3
    not a hole. More like scrapes down the sides of the piston. Does that change anything?

  4. #4
    David Drkvampire2001's Avatar
    Join Date
    Jul 2011
    Location
    Edgerton, Wisconsin, United States
    Posts
    2,857
    +1
    30
    scrapes down the side dont really mean it got lean, i mean it coudl mean that but generally that means no oil. hvae you verified your oil pump is working and the lines are connected with no air bubbles?

  5. #5
    Guy working on it said he reprimed the oil system and that it was working. Is it possible that only 1 cylinder gets no oil? The other two are perfect.

    I am going to do the piston again and the fuel pump. I guess I can ask him to tripple check the oil injection on the PTO.

  6. #6
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by Drkvampire2001 View Post
    and MOST IMPORTANT upgrading to the triple outlet fuel pump
    The 780s came factory with a pentagon style triple outlet pump. You can get a rebuild kit for around $20, and is a good idea to do so.

  7. +1 by:


  8. #7
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by xanthras View Post
    Had all three carbes rebuilt
    Do you know what needle settings were used after the carbs were rebuilt?

  9. #8
    It already has the tripple outlet pump. Not sure of the needle settings. Will have to find out.

  10. #9
    David Drkvampire2001's Avatar
    Join Date
    Jul 2011
    Location
    Edgerton, Wisconsin, United States
    Posts
    2,857
    +1
    30
    Quote Originally Posted by xanthras View Post
    Guy working on it said he reprimed the oil system and that it was working. Is it possible that only 1 cylinder gets no oil? The other two are perfect.

    I am going to do the piston again and the fuel pump. I guess I can ask him to tripple check the oil injection on the PTO.
    I would do that, and I would pre mix the tank for maybe the first 2 until you can verify oil is getting to the cylinder

  11. #10
    David Drkvampire2001's Avatar
    Join Date
    Jul 2011
    Location
    Edgerton, Wisconsin, United States
    Posts
    2,857
    +1
    30
    Quote Originally Posted by BlueFishCrisis View Post
    Quote Originally Posted by Drkvampire2001 View Post
    and MOST IMPORTANT upgrading to the triple outlet fuel pump
    The 780s came factory with a pentagon style triple outlet pump. You can get a rebuild kit for around $20, and is a good idea to do so.
    Thanks for the correction! ive never ad a 780 but good to know!

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 sl 780 burning up spark plugs
    By JBurnt in forum Polaris Tech Tips and Info
    Replies: 4
    Last Post: 06-27-2015, 03:59 PM
  2. Replies: 1
    Last Post: 06-04-2014, 01:58 PM
  3. 2001 kaw 1100 zxi keeps burning up the front piston
    By XcrabnutzP in forum Open Discussion
    Replies: 6
    Last Post: 08-30-2013, 06:57 PM
  4. Burned up a piston
    By kl7741 in forum Polaris Open Discussion
    Replies: 24
    Last Post: 05-13-2010, 08:18 AM
  5. burning up back piston 94 sl650
    By Codered346 in forum Polaris Projects
    Replies: 1
    Last Post: 04-07-2010, 09:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •