Results 1 to 6 of 6
  1. #1

    Very Hard to Start after running

    I have a 2005 RXP that just hit 100 hours. Bought it last season. Occasionally after riding for a while I'd stop in the middle of lake mead, jump in the water for a few minutes and when I got back on the ski it would take 5-8 minutes before starting.

    Fast forward to this season, I seem to have the problem all the time.

    I've done tune up and replaced battery with an odessey. The computer only shows codes for my VTS which isn't working.

    Any suggestions would be awesome!


  2. #2
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    replace the starter soleniod/relay..
    Last edited by Snoman; 08-05-2013 at 11:03 AM.

  3. #3
    Thanks for the fast reply!!

  4. #4
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by Maddbones View Post
    Thanks for the fast reply!!
    You bet,welcome to GH.hope you enjoy your stay...

  5. #5
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Starter relays are a common thing to replace on these doos.. last time I was getting 1 the dealership had 45 in stock...

  6. #6

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 94 SLT hard to start after sitting
    By Drkvampire2001 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-18-2012, 08:59 PM
  2. '98 hard to start after running
    By barkster in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 04-22-2012, 10:11 AM
  3. 2002 Polaris 1200 TXI very hard to start.
    By Jkstr in forum Polaris Open Discussion
    Replies: 1
    Last Post: 09-25-2011, 05:55 PM
  4. 96 Seadoo XP 800 -Very hard to start after being shut off
    By Jimnut in forum 2-Stroke Performance
    Replies: 7
    Last Post: 08-13-2010, 12:27 PM
  5. Hard to start after a few days
    By griffin55 in forum Yamaha PWC Performance (2-stroke)
    Replies: 13
    Last Post: 06-09-2010, 09:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •