Results 1 to 6 of 6
  1. #1
    macgyver's Avatar
    Join Date
    Jul 2009
    Location
    Delaware
    Posts
    134

    2010 Rxtx-260 overheating

    I know it's been awhile since I've been on the site or been on the forums but haven't spent a lot of time on the ski this summer and was problem after problem last year. Ok so towards the end of last season I lost my prop due to someone hitting a sandbar that was more rock than sand. So I got a new prop and wear ring. Now I went with a 15/22r for now and haven't had it repitched yet. I can runn the ski all day if I stay below 7000 rpm. Once I get above 7000 the temps starts climbing fast. Not is it that I'm not getting enough water through the pump to properly cool. Also my rpms and speed are way down but am contributing that to the prop. Could all MUAH!! Problems be one in the same. Makes sense to me just getting another opinion


  2. #2
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,991
    +1
    455
    I bet the hose from the pump to hull split! What nozzle are you running?

  3. #3
    macgyver's Avatar
    Join Date
    Jul 2009
    Location
    Delaware
    Posts
    134
    Running stock nozzle

  4. #4
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,991
    +1
    455
    Quote Originally Posted by macgyver View Post
    Running stock nozzle
    83 or 87?

  5. #5
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,849
    +1
    742
    Click image for larger version. 

Name:	IMG_1340.jpg 
Views:	66 
Size:	45.2 KB 
ID:	309415

    See if this hose is split like this one, pump to the iBr. There have been several of us that have had this happen!

  6. #6
    macgyver's Avatar
    Join Date
    Jul 2009
    Location
    Delaware
    Posts
    134
    Ok will do. Thank u

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2010 RXTX-260 IBR system
    By Glade Rider in forum 4-Tec Performance
    Replies: 14
    Last Post: 10-07-2010, 09:51 PM
  2. 2010 RXTX 260 ECU / GPS Limiter
    By Glade Rider in forum 4-Tec Performance
    Replies: 54
    Last Post: 09-25-2010, 08:48 PM
  3. Intake Install / 2010 RXTX-260
    By Glade Rider in forum 4-Tec Performance
    Replies: 10
    Last Post: 09-20-2010, 10:31 PM
  4. 2010 RXTX-260 SC Washer Question
    By Glade Rider in forum 4-Tec Performance
    Replies: 4
    Last Post: 09-15-2010, 02:15 PM
  5. FS 2010 rxtx 260 and IS models ecu rs no gps limiter
    By rxpstan in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 08-05-2010, 08:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •