Results 1 to 7 of 7
  1. #1

    Join Date
    Aug 2013
    Location
    Lake Anna va
    Posts
    2

    2008 RXP-X lost 3-4 pounds of boost 2 hours after build.

    I Modified ski this winter with 38hrs. Ski was perfect 8500-8600 rpms 14-15 #'s boost....super fast. At forty hours RPMS max at 8250 boost down to 10-12 #'s. Checked all connections everything seems tight. No signs of pushed gasket (oil/water). Found fuel leak at tank on the Riva RRFP oietiker clamp. I had all braided hoses for tank to reg with an fittings made and that fixed fuel leak and the ski ran much better than it had since the first 2 hours( 12#'s boost same rpms). During this whole situation it had started fine and randomly would not start back until it sat for 25-45min. I assumed it was related to the fuel/pressure leak but that is fixed and left me sitting again yesterday. Any ideas on either/both situations? 2008 RXPX xx riva housing/wheel, RIVA RRFP, Riva water box and rear outlet, Riva ecu 50lb inj, Riva intake upgrade, Riva air intake, 15/22r riva imp, Riva intake and opas delete, 2 degree wedge. Titanium valve upgrade. Boost gauge.


  2. #2
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,994
    +1
    455
    Quote Originally Posted by Phillips View Post
    I Modified ski this winter with 38hrs. Ski was perfect 8500-8600 rpms 14-15 #'s boost....super fast. At forty hours RPMS max at 8250 boost down to 10-12 #'s. Checked all connections everything seems tight. No signs of pushed gasket (oil/water). Found fuel leak at tank on the Riva RRFP oietiker clamp. I had all braided hoses for tank to reg with an fittings made and that fixed fuel leak and the ski ran much better than it had since the first 2 hours( 12#'s boost same rpms). During this whole situation it had started fine and randomly would not start back until it sat for 25-45min. I assumed it was related to the fuel/pressure leak but that is fixed and left me sitting again yesterday. Any ideas on either/both situations? 2008 RXPX xx riva housing/wheel, RIVA RRFP, Riva water box and rear outlet, Riva ecu 50lb inj, Riva intake upgrade, Riva air intake, 15/22r riva imp, Riva intake and opas delete, 2 degree wedge. Titanium valve upgrade. Boost gauge.
    try a new set of spark plugs

  3. #3
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    The no start sounds like a starter relay.

  4. #4

    Join Date
    May 2005
    Location
    Minneapolis
    Posts
    763
    +1
    26
    you lost tension in your spring washers probably - but check compression.

  5. #5

    Join Date
    Aug 2013
    Location
    Lake Anna va
    Posts
    2
    That was my next plan check charger clutch. did total service to charger with new wheel....did put in new plugs. Thanks for any advice.

  6. #6
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    You sure it's not just humidity and heat? How much have your temps changed during your winter runs until now?

  7. #7
    dnielsen's Avatar
    Join Date
    May 2008
    Location
    Shreveport, Louisiana
    Posts
    2,018
    +1
    94
    Boost leak? Check the manifold......,,recheck slip!

  8. +1 by:


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Losing power at 14 pounds of boost. Going from 14 to 0 on full throttle
    By quinn.jeremyz in forum Yamaha PWC Performance (4-stroke)
    Replies: 15
    Last Post: 05-16-2016, 07:03 PM
  2. Wanted a couple more pounds of Boost
    By immred in forum 4-Tec Performance
    Replies: 21
    Last Post: 04-14-2014, 03:28 PM
  3. ??? with 16 pound of boost what is the injectors side??????
    By rxpredviper in forum 4-Tec Performance
    Replies: 11
    Last Post: 02-08-2010, 09:05 PM
  4. 2008 RXP-X DEAL of a LIFETIME!
    By REID2168 in forum Sea Doo 4Tec Skis
    Replies: 17
    Last Post: 09-17-2008, 08:47 PM
  5. Video run of 2008 RXP-X with Eric Lagopolous
    By JordanHaye in forum 4-Tec Performance
    Replies: 71
    Last Post: 04-22-2008, 03:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •