Results 1 to 6 of 6
  1. #1
    Turbofab's Avatar
    Join Date
    Feb 2013
    Location
    Clearwater FL
    Posts
    330
    +1
    21

    Oil cooler all corroded think I found the leak (pics)

    Well my buddy has a rtx 07 and its been leaking oil bad, took off the intake manifold to get to the oil cooler and this is what i found. lol thinks its leaking oil.





  2. #2
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Just put some jb weld on it and that should fix it...
    Lmfao...

  3. +1 by:


  4. #3
    Turbofab's Avatar
    Join Date
    Feb 2013
    Location
    Clearwater FL
    Posts
    330
    +1
    21
    Lmao yea ill go get some

  5. #4
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,179
    +1
    97
    What did he do, leave salt water deep in the hull? Or was it converted to open cooling?

  6. #5
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    I've got a good one if he needs it

  7. #6
    Turbofab's Avatar
    Join Date
    Feb 2013
    Location
    Clearwater FL
    Posts
    330
    +1
    21
    Its a salt water ski, lives on a lift.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Think I found the threshold for rough water ocean riding
    By XDAILY in forum Sea Doo Open Discussion
    Replies: 45
    Last Post: 04-21-2015, 11:40 AM
  2. i think i found the problem for the oil leakage
    By tysonfzr in forum Yamaha PWC Performance (4-stroke)
    Replies: 11
    Last Post: 01-03-2012, 06:14 PM
  3. i think i found the muffler bearings
    By superduty in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 07-03-2007, 08:14 PM
  4. Found the GREMLIN! pics......................
    By WATER WOODY in forum Yamaha PWC Performance (2-stroke)
    Replies: 51
    Last Post: 10-23-2006, 11:12 PM
  5. I think we found the problem...surging part 2
    By carbuff91 in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 05-26-2006, 09:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •