Results 1 to 5 of 5
  1. #1

    Join Date
    Jun 2011
    Location
    Columbus, MS
    Posts
    22

    Virage oil sending unit leaking

    Well I took the ski out today and when I returned I had a ton of oil in the hull. I saw where it was running down the oil tank and worked my way to the sending unit. As soon as I touched it I was able to pull it right out with no restriction. I did not see a clamp on it nor is there one in the hull laying around. So....how does this little black sending unit stay put in the hole?? Oh this is a 2002 polaris virage


  2. #2

  3. #3

    Join Date
    Jun 2011
    Location
    Columbus, MS
    Posts
    22
    That was easy thanks! I should have used the search from the start! i actually thought of the hose clamp but figured the tank is so rigid that it would not squeeze it. So I guess it has worked nicely for ya? That's a fairly large lip would a regular automotive hose clamp not work?

  4. #4
    LaveyT's Avatar
    Join Date
    Jul 2008
    Location
    Cincinnati
    Posts
    672
    +1
    10
    I think a regular hose clamp would work but Bryan P sent me a narrow one. I would put the clamp up high on the tank flange. I did my preventive maintenance last winter and it seems to have paid off with a bunch of trouble free riding this year (knock on wood) Click image for larger version. 

Name:	IMG_20130329_155144_669.jpg 
Views:	43 
Size:	70.9 KB 
ID:	309432

  5. #5

    Join Date
    Jun 2011
    Location
    Columbus, MS
    Posts
    22
    Nice looking ride! Mine needs paint as the clear coat is gone and the paint is rough. Ive had it since new but the last 5 or so years I have really neglected it. Not sure if I want to paint it or not really, the seat is rather nasty too, no rips but scrubbing it doenst get all the crud off. From a distance it looks golden though! Just like yours but yellow.

    However Ill do the hose clamp tomorrow and take the nephew tubing! Well actually its suppose to rain tomorrow.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Oil Sending unit / 2003 Polaris Virage I
    By Mike Quante in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-26-2011, 06:23 PM
  2. pair of 96 sltx leaking oil around oil sending unit
    By mrjetskey in forum Polaris Open Discussion
    Replies: 1
    Last Post: 09-28-2008, 05:04 PM
  3. Oil Sending Unit Broken or No
    By newtball in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 07-16-2008, 07:23 AM
  4. Oil Sending Unit Question
    By newtball in forum 2-Stroke Performance
    Replies: 1
    Last Post: 07-16-2008, 07:22 AM
  5. 1997 SLT780 Oil sending unit
    By redhead780 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-08-2008, 08:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •