Results 1 to 3 of 3
  1. #1

    08ultra250x jumping idle and hesitation

    I just bought a 2008 ultra 250x a couple of days ago with 60 hours. I've owned plenty of skis before but this is my first supercharged waverunner so please have patients with me if I don't know what your talking about. I drove 2 hours to see it, test drove it and it ran great hitting 7800+ rpm. I took it home, put it on the water and when I first started it up the idle was jumping from 1100-1600 which I thought was weird. started to accelerate and hit about 30 with nothing out of the ordinary. when I tried to go full speed I could only hit about 6500 rpm and it feels like there's a miss or hesitation. when holding the throttle all the way open it will suddenly speed up like it got a burst of energy and then go back down. top speed its about 50-55. my guess is something came loose on my 2 hour drive back? but im not sure. any advise would be great thanks.


  2. #2
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    Check the intake airhorn isn't sucking up against the side of the hull. Remove and throw the plastic pulley cover, makes it easier to check and wash and keep clean the pulleys and belt. Check them failing that replace the spark plugs. Make sure after a ride you give it good blips of the throttle to clear out all water from the exhaust.

  3. #3
    Quote Originally Posted by nicjak View Post
    Check the intake airhorn isn't sucking up against the side of the hull. Remove and throw the plastic pulley cover, makes it easier to check and wash and keep clean the pulleys and belt. Check them failing that replace the spark plugs. Make sure after a ride you give it good blips of the throttle to clear out all water from the exhaust.
    By the airhorn im assuming you mean the air intake right at the front of the engine? if so all the tubes are connected and it looks ok. took the pully cover off and they look good along with the belt but I don't know how to check the tention. the spark plugs aren't bad but i'l replace them to see if it helps.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help!! 1300 won't idle and bogs!!
    By dcs191919 in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 05-26-2009, 11:21 AM
  2. gp800r no idle and rough
    By gp8r in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 02-02-2008, 09:40 AM
  3. Jumped wave and GP 1200 died...will not turn over.
    By iam026tb4u in forum Yamaha Open Discussion
    Replies: 6
    Last Post: 08-27-2007, 06:17 PM
  4. changed top end, rough idle and deto sounds
    By cretamk in forum 2-Stroke Performance
    Replies: 3
    Last Post: 07-24-2007, 06:01 AM
  5. 94 650 xp rough idle and flat spots
    By hotrod_sxty8 in forum 2-Stroke Performance
    Replies: 8
    Last Post: 05-20-2007, 11:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •