Results 1 to 6 of 6
  1. #1

    Polaris sl 1050 Weak spark on Mag

    My polaris sl 1050 1997 has weak spark on the mag cylidner ( the one closest to the fuel tank ) it spark once right and the rest is either weak or no spark at all the ski starts and revs 6100 on water what might be the problem thank you ( it
    doesnt have the stator update kit )

    Thank you very much for your help!


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,595
    +1
    1,276
    It seems likely that you need the Ignition Update kit.

    Alternative, with no guarantee, is to replace the stator with a known good 'original type' stator. If you are lucky, that might solve the problem. But, the original stators are known to fail over time, so the replacement 'old style' stator may or may not last very long.

    It is also possible that the old CDI is failing, either by itself, or in conjunction with the old stator.

    The best bet is to install the Update Kit.

  3. #3
    Where is it possible to find this ignition update kit ?


    Thank you for responding quick!

  4. #4
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,571
    +1
    35
    Quote Originally Posted by Polaris sl 780 View Post
    My polaris sl 1050 1997 has weak spark on the mag cylidner ( the one closest to the fuel tank ) it spark once right and the rest is either weak or no spark at all the ski starts and revs 6100 on water what might be the problem thank you ( it
    doesnt have the stator update kit )

    Thank you very much for your help!
    I would do the "ignition coil tests", I believe it will also test the ignition wires to verify those parts are good.
    Having 2 working cylinders you should be able to compare voltages from the CDI to the coil.

  5. #5
    Rasta Mon Condoms We Be Jammin!!!!! TxVirageTx's Avatar
    Join Date
    Aug 2006
    Posts
    5,776
    +1
    400
    unthread the boot of the wire end.clip about 3/8" off the wire,rethread the end back on

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,595
    +1
    1,276
    Quote Originally Posted by TxPro1200 View Post
    unthread the boot of the wire end. clip about 3/8" off the wire, rethread the end back on
    My bad for skipping over these basic checks and jumping to the Ignition Upgrade Kit

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97 polaris sl 1050 spark issues
    By VinnyM in forum Polaris Tech Tips and Info
    Replies: 0
    Last Post: 06-23-2015, 11:45 AM
  2. Sl 1050 Weak Spark on MAG cylinder only
    By dswelch in forum Polaris Open Discussion
    Replies: 4
    Last Post: 06-24-2012, 05:35 PM
  3. Advice on polaris sl 1050
    By Matty Gough in forum Polaris PWC Performance
    Replies: 4
    Last Post: 05-21-2012, 02:15 PM
  4. 1999 Polaris SLX 1050 - Weak Spark??
    By shornback in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 11-05-2011, 09:46 PM
  5. 1999 1050 SLTX, no spark on MAG Cylinder
    By dragpro in forum Polaris Open Discussion
    Replies: 7
    Last Post: 08-15-2008, 12:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •