Results 1 to 8 of 8
  1. #1

    Join Date
    Apr 2012
    Location
    Southern California
    Posts
    308

    Virage starting issue

    I have a 2002 virage that will start and run fine if you hold the button down I have put in a brand new lr module and emm and swaped my emm and lr out of my genisis and still does it if you tap the button 5 to 10 times it will stay running what could cause this the ski runs fine once it's running


  2. #2
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,518
    +1
    1,266
    cps might be unreliable. Without a steady signal, the fuel pump shuts off. Try swapping it out. Quick and easy.

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,574
    +1
    1,272
    Start solenoid has an internal snubber diode. If that diode goes bad then when you release the start button an electrical spike can recoil into the system and shut the engine down.

    If you still have the original black start solenoid with metal backing plate, replace it regardless. Those are known to corrode internally and fail without warning.

  4. #4

    Join Date
    Apr 2012
    Location
    Southern California
    Posts
    308
    What do I replace it with

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,574
    +1
    1,272
    Quote Originally Posted by jetski4ever View Post
    What do I replace it with
    The current part number is a newer design that is all plastic, no metal backing plate. Much more reliable.

    Same part is used on some seadoo models. My signature links have the actual part numbers.

  6. #6

    Join Date
    Apr 2012
    Location
    Southern California
    Posts
    308
    Okay I swaped out the CPS and the starter solinoid and no change its weird I took this ski out to the lake yesterday and it hard to start and the rpms are all over the place but after 10 min of riding it fine it runs and idles great and yhe idle is steady and I don't get it if I go to start it up on land it runs like crap but as soon as I run it in the water it's fine

  7. #7
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,518
    +1
    1,266
    I'll take a swag and say it's the emm. Run a hairdryer on it for a bit on land and see if the emm is warm if it runs ok

    the emm is water cooled so I will guess that thermal expansion at work and you have a bad solder joint.

    can we assume once it's warmed up it idles fine for a couple of seconds out of water?

    exact info is urgent here. We can't make good guesses without it!

  8. #8

    Join Date
    Apr 2012
    Location
    Southern California
    Posts
    308
    Ya it's weir because both of my skis do it they both run like crap and then when their warm their great skis no noises nothing perfect they start right up first try and can idle for days so I think you right

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Cold start issue with 2002 Virage TXi
    By evowagon in forum Polaris Open Discussion
    Replies: 33
    Last Post: 01-29-2014, 10:51 PM
  2. 2000 virage 700 starting issue
    By scubadw in forum Polaris Open Discussion
    Replies: 7
    Last Post: 05-26-2011, 07:16 AM
  3. 2001 Polaris Virage Starting Issues. Please Help
    By sofreshincali in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-23-2010, 12:42 AM
  4. Polaris Virage 700 starting issue, need help
    By Quad411 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 04-25-2009, 10:17 AM
  5. Virage I 2002 Starting Issues
    By fbsmith in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 04-14-2008, 11:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •