Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 34
  1. #1

    SLX 780 Impeller questions

    First off y'all have a wonderful site! I have been a lurker for a while and I believe in the search bar.

    I purchased what I believe to be a 95 SLX 780. I checked compression -122-125-125, updated fuel lines, replaced fuse for dash- which still won't work. Anyways, the first time we took it out, with me and wifey on it, it would not plane out. I didn't know if it was slipping or cavitating. I took the seat off at the ramp and checked for water leaks around the shaft floating and wot. No major leaks. So I pulled the pump last night, checked d shaft-good, coupler- good, gap between impeller and wear ring-.016. So I don't know what's wrong with it not taking off. It revs fine and will fly when it finally takes off. I weigh around 300 and wifey around 120. Also I noticed a chunk missing out of the fin on the stator. Attached is a picture of mine with the shaft still in it. The other one is a picture I found on eBay. Any info will help. Thanks!


    Click image for larger version. 

Name:	image.jpg 
Views:	44 
Size:	17.8 KB 
ID:	309534Click image for larger version. 

Name:	image.jpg 
Views:	55 
Size:	69.7 KB 
ID:	309535


  2. #2
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Welcome to the Hulk - You have probably already found this link, but if not, check it out.....

    If it has trouble getting up on plane, and seems like the motor is just revving, you may be sucking air into the pump intake. Need to make sure that the ride plate and intake grate are well sealed with silicone sealant. Also check in the pump tunnel for any debris.

    .016 is getting close to the limit, but shouldn't keep you from jumping on plane. I would imagine with two riders on the SLX it is going to take on a pretty high angle when hitting the throttle, which may add to the air (ventilation) issue if the grate and plate are not sealed. Same issue with 1 rider??

    Was the ski lunging forward pretty good when you were WOT testing at the ramp?? My 750 will rock my truck and trailer back and forth when applying that much throttle on the trailer.....

  3. #3
    Yes against the trailer it was shaking the Tahoe! With one rider it will rock and roll! Just with 2 it don't want to plane out. Just drives around IN the water not on top. Since I have no big leak floating or wot around the drive shaft you think the ride plate and intake grate needs to be resealed? Does my impeller look bad? Thanks for the help!

  4. #4
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Impeller doesn't look great, but shouldn't cause what you are describing. If the intake grate and ride plate aren't well sealed, they will allow air from the jet pump cavity to leak into the intake tunnel ventilating the prop. They will not cause water leaks into the hull. When you take off and it won't plane out, does the engine run up to full rpm and feel like its not grabbing, or does it just not want to get up and go.....??

  5. #5
    It revs up and seems to be on the rev limiter. I can back off the gas a little and it seems to want to take off then.

  6. #6
    What is the proper name for the aluminum piece behind the impeller? It kinda looks like a propeller but it don't turn.

  7. #7

  8. #8
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by mudslinger83 View Post
    Stator?
    yes stator. If it has chips, that will affect the efficiency of the drive, but will not cause what you are describing. If you get on the throttle and rpms go up to the limiter you are more than likely sucking air at the ride plate / intake grate.....

    How do the drive shaft splines look? Was there a rubber bumper on both sides of the shaft??

  9. #9
    Click image for larger version. 

Name:	image.jpg 
Views:	55 
Size:	70.1 KB 
ID:	309550

    I don't know about a rubber bumper. But the shaft spines looked good. So I need to reseal or replace the ride plate and intake grate?

  10. #10
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Reseal - But you don't really need to pull them off. First you can try getting under the ski and getting a good bead of silicone on all the mating points of the plate and the grate to the hull. Make sure you smooth it out, but apply liberally....

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 95 polaris slx 780 reed valve question
    By polarisslx780 in forum Polaris Open Discussion
    Replies: 8
    Last Post: 12-29-2010, 07:47 PM
  2. MFD question and Leak question 1995 SLX 780
    By koryk in forum Polaris Open Discussion
    Replies: 3
    Last Post: 04-30-2010, 01:40 PM
  3. SLX 780 shaft alignment Question???
    By Lockout in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 05-27-2008, 09:46 PM
  4. 95 polaris slx 780 trim question
    By slx780 in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 02-05-2008, 06:16 PM
  5. Polaris SLX 780 Question
    By mtiller in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-03-2007, 11:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •