Results 1 to 8 of 8
  1. #1

    Join Date
    Feb 2006
    Location
    Southern California...Oceanside
    Posts
    71
    +1
    1

    2004 r12x stalling and knocking noise at low rpms

    I have a 2004 R12X. It will stall intermittently at idle. It also has a knocking noise but only idle. Once you get out of idle it runs fine and the knocking noise will go away. I even bumped the idle to about 1300 rpm to see if that changed anything and it didnt help. The ski has 21 hours on it. No warning lights or codes. The fuel is new and 91 octane. I dont know much about the Honda PWC's. Its been sitting for awhile. Any help or opinions would be greatly appreciated.

    Thank you


  2. #2
    is your oil ok or is it milky?

  3. #3

    Join Date
    Feb 2006
    Location
    Southern California...Oceanside
    Posts
    71
    +1
    1
    I changed the oil and filter because it was sitting for so long. The old oil condition and level was fine.

  4. #4
    id start with new plugs then maybe check the coil packs, unplug them one at a time to identify which one is a problem

  5. #5
    supermac's Avatar
    Join Date
    Dec 2005
    Location
    Mooresville, NC
    Posts
    406
    +1
    10
    plugs first...

  6. #6
    Its most likely the rubber insert that goes between the teeth on the motor and the teeth on the driveshaft. That's how my brothers acted when that went bad.
    http://www.hondapartshouse.com/oempa...r-driveshaft-1 its #3

  7. #7

    Join Date
    Aug 2013
    Location
    Denver, NC
    Posts
    31
    +1
    1
    Was the tank empty before you added new fuel? Try running premium with stabilizer for a tankful and see if it clears up.

  8. #8

    Join Date
    Aug 2013
    Location
    Denver, NC
    Posts
    31
    +1
    1
    ...and new plugs!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 9
    Last Post: 08-08-2010, 01:40 PM
  2. 99 SLTH - Top End Runs great, bogs down at low RPM
    By thiagoavila in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-29-2010, 12:02 PM
  3. RXP Knock sensor question/ Low RPMs. Please help!
    By ADHDave in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-21-2010, 06:11 AM
  4. fx160 2006, wont run properly at low rpm's
    By Turbo Retro in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 02-01-2010, 05:19 AM
  5. bogs down at low rpms
    By RiverRat19405 in forum 2-Stroke Performance
    Replies: 0
    Last Post: 07-01-2007, 06:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •