Results 1 to 7 of 7
  1. #1

    BIG PROBLEM with XP DI

    Hello, I have a very Big Problem. I go to my Xp Di, and wants to reset the Throttle Body... because, in zero Position it shows 17%. Then i Put the reset Button on my Can Doo Pro, and now the Throttle Position in 0% and if i give gas, the Throttle Body donīt move !!!! What is the Problem ? Please help, i want to drive in holiday with the Ski next week...please help me...


  2. #2
    SURFnTURF's Avatar
    Join Date
    May 2007
    Location
    Australia
    Posts
    878
    +1
    11
    Check the throttle cable and the oil pump cable

  3. #3
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,517
    +1
    1,264
    I assume you loosened the allen screw to let the throt plate fully close. I've had them bind in the full close position. Try turning the stop screw in a couple of turns.

    was there an issue that made you reset the tps?

  4. #4
    I converted from thumb gas to finger gas. Then at idle the throttle was 17% open, I pressed on reset, and since nothing works. The Lap op with Candoo hangs every time. If I give gas, the throttle no longer going to open ! You can give full gas on the fingergas, and the throttle is not even 1% on.

  5. #5

    Join Date
    Aug 2012
    Location
    Garland, Tx
    Posts
    256
    +1
    12







  6. #6
    You are testing with engine not running, right?

    First things first. REad the ski again and report back what the adaptation values are for both the MAG and PTO TPS sensors. If the adaptation values are beyond a certain value, then the MPEM will not reset the TPS. Clear the faults and check to ensure that there are no active faults related to all the TPS sensor faults (range, adaptation, etc)

    Let us know what you see.

  7. #7
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,517
    +1
    1,264
    the candoo issue needs to be resolved first. The OP isn't able to read anything at the moment it seems

    can we assume the throttle plates open as expected?

    we're also dealing with a language issue here.

    I will assume:

    thottle plates are opening as expected when the throttle lever is used.
    candoo can provide any readings as the software is now hanging up
    there was nothing other then a bad reading which got you to press the reset button for the tps in candoo.

    please contact candoo, your hardware may need reflashing/software may need reloading if the candoo hands when you start it up.

    if candoo hangs when you open the throttle, that's another issue.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Big problem with rxpx 260
    By papafever in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-18-2016, 01:04 PM
  2. need help with XP-DI fuel line
    By roundtopjeff in forum 2-Stroke Performance
    Replies: 5
    Last Post: 05-28-2013, 11:40 AM
  3. found big problem with my GP Pump shoe
    By Mr1300 in forum Yamaha PWC Performance (2-stroke)
    Replies: 15
    Last Post: 12-17-2007, 10:39 PM
  4. Well, I had a big problem with my Ski this Weekend...
    By LiquidDI in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-20-2007, 10:00 PM
  5. OK big problem with the ski
    By mikegpr03 in forum Yamaha PWC Performance (2-stroke)
    Replies: 15
    Last Post: 03-26-2007, 06:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •