Results 1 to 2 of 2
  1. #1

    Question starter problems 93 kawasaki supersport xi

    riding ski in water all day than went to start it and when i hit the stert button it just clicked so i replaced starter solenoid still just clicks the solenoid anything i missed and by the way stater is not hooked up does it with or with out starter hooked up no change any help would be very nice thanks


  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    285
    Welcome aboard, kartingguy!

    Did you try a different battery? Clean & tighten the connections? Jumping directly from the battery to the starter?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 93 waverunner lx650 starter problems>?
    By simpleton in forum Yamaha Old School Skis
    Replies: 3
    Last Post: 07-11-2016, 12:53 PM
  2. 93 Kawasaki 750ss Problems
    By wpb750ss in forum Kawasaki PWC Performance (2-stroke)
    Replies: 7
    Last Post: 03-14-2012, 09:59 PM
  3. 1995 750 XI SS Starter problem?
    By jcc011185 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 6
    Last Post: 10-05-2010, 08:06 PM
  4. 93 Kawasaki 750 SS problems running
    By nickroun2002 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 4
    Last Post: 08-11-2010, 05:52 PM
  5. 94 supersport xi ignition problem
    By jetskibill9999 in forum Polaris PWC Performance
    Replies: 1
    Last Post: 11-25-2008, 11:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •