Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    Question 1997 polaris 1050 sl reving out

    i have a 1997 polaris 1050 sl the watercraft starts up no problem runs but when you rev it up it maxes out at 4000 rpm any ideas


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Could be the rev limiter kicking in. Does it sound like its misfiring at 4000 RPM?

  3. #3
    yes it does sound like that its just firng at the same rpm like somthing is stuck and the red light on mfd is flashing

  4. #4
    how do i check the rev limter and can i bypass or do i have to replace it

  5. #5
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    If the red light is flashing, what message is the MFD giving you? Hot, Oil, or Fuel?

  6. #6
    fuel but there is alot of gas in it

  7. #7
    the mfd has also been randomly turning off then coming on again

  8. #8
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Then I am betting your fuel sender isnt working. The floats in them are known to go bad. They cost about 30 bucks to replace. If you go into your electric box, disconnect the gray wire from the terminal board and see if the problem goes away. I would still replace the float. Nothing worse than not knowing how much gas you have.

  9. #9
    so is that what could be causing it to revout as well

  10. #10
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Im guessing not. I just looked at the electrical diagram for that machine and the only thing that appears to trigger a limp mode is overheat. Im going to guess if pulling the grey wire doesn't change anything, you have a failing stator.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1997 Polaris 1050 SL just not running right
    By walimu in forum Polaris PWC Performance
    Replies: 8
    Last Post: 09-02-2016, 02:53 AM
  2. 1997 polaris 1050 sl reving out at 4000 rpm red light flashing
    By frostsnowman in forum Polaris PWC Performance
    Replies: 3
    Last Post: 08-09-2013, 09:45 AM
  3. polaris 1050 sl 1997
    By NJpolaris1050sl1997 in forum Polaris Projects
    Replies: 18
    Last Post: 07-05-2008, 05:35 PM
  4. 1997 Polaris 780 SLT (Cutting out at full throttle)
    By harleyfun1996 in forum Polaris Open Discussion
    Replies: 20
    Last Post: 03-24-2008, 01:02 PM
  5. 1997 Polaris 1050 MFD
    By raydmo in forum Polaris Open Discussion
    Replies: 4
    Last Post: 03-20-2008, 09:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •