Results 1 to 9 of 9
  1. #1

    Join Date
    Aug 2013
    Location
    norway,me
    Posts
    88

    2001 di wont run.

    bought a 2001 virage txi with the engine blown.had the #3 cylinder go thru the bottom of the case.i got another block and crankshaft from the seller.i swapped it all over with a new piston.jug cleaned up at .5mm.when I try to start it.it starts and quits almost immediately.a couple times I got it to rev up briefly.it always starts and idles for a few seconds but that's it.light isn't blinking unless its in reverse.the ski has 55.4 hours.just did fuel pressure and its 30lbs.return is zero unless u pinch retun line.but doing that doesn't make it run any better.i did all the voltage checks on the coil primary and injector fireing wire.all info I got here.thank you.tach seems accurate when its running.i am a 40 auto mechanic with a speacalty on auto trans but I cant seem to figure this out.no dealers around here will check it out.they don't work on those they say.any help much appreciated.i am new to this ski stuff and this site,which is excellent by the way.i also have a virage carb model.thanks update--got the tank pulled ahead and pump out.sure enough the regulator had fallen off.ill try to do the fix on here.if this was the problem,wouldnt it of run when the return line was pinched.?i think this is the wrong forum besides.my 1st one
    Last edited by xltier; 08-10-2013 at 02:18 PM.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,577
    +1
    1,272
    Welcome

    Request. Please break your posts into paragraphs. Makes it much easier to parse out what you are saying

    I suspect you are mis-identifying which fuel hose is the fuel supply and which is the return fuel line. The return fuel line has the schrader valve tee installed inline between the fuel injectors and the fuel tank return nipple.

    Get the fuel pump regulator fixed and see what you then have for fuel pressure. We can go from there if further diagnostics are required.

  3. #3

    Join Date
    Aug 2013
    Location
    norway,me
    Posts
    88
    thank you.

  4. #4

    Join Date
    Aug 2013
    Location
    norway,me
    Posts
    88
    repaired the regulator in the gas tank..i now have 30lbs on the syhrader valve.it still starts and stops.only runs a couple seconds then dies.i have the pressure gauge connected. It will not rev up with the throttle. All 3 heads get warm equally. The gauges are working. I spaced these comments out but they still run together.how do u do paragraphs?

  5. #5
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,519
    +1
    1,268
    visit the 447 sig links for basic troubleshooting of the injector and ignition systems. Plenty of stuff to look at.

    use a shift/return to force a new line.

    first things first..you must be using the correct spark plugs. There are NO substitutions allowed at club Polaris

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,577
    +1
    1,272
    Quote Originally Posted by xltier View Post
    repaired the regulator in the gas tank..i now have 30lbs on the schrader valve.

    it still starts and stops. only runs a couple seconds then dies. i have the pressure gauge connected.

    It will not rev up with the throttle.
    All 3 heads get warm equally.
    The gauges are working.

    I spaced these comments out but they still run together. how do u do paragraphs?
    Try a different web browser, or a different computer.

    30PSI sounds high. If you pinch flat the return fuel line between the schrader valve tee and the fuel tank fitting, does the fuel pressure rise higher? If not, something is wrong.

    If you continue to hold down the Start button after the engine starts, does it keep running?

  7. #7

    Join Date
    Aug 2013
    Location
    norway,me
    Posts
    88
    yes it does. my gauge is a little high starting off. It stays running longer but not great.coil primary is 2.5 -3.0 volts dc/???

  8. #8
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,577
    +1
    1,272
    Quote Originally Posted by xltier View Post
    yes it does. my gauge is a little high starting off. It stays running longer but not great.coil primary is 2.5 -3.0 volts dc/???
    What does?

  9. #9

    Join Date
    Aug 2013
    Location
    norway,me
    Posts
    88
    yes ,the pressure raises a little more if u pinch the hose off.-------using a flash bulb spark checker I think it loses spark after it starts.i cant say for sure if it runs longer with the start button down.i don't think so.fuel pressure stays at normal until the motor stops completely.i am actually getting 20 volts at the injector and more if it fires up.----cant get a lot of voltage on the coil terminal.but it does spark decent when cranking.--------I have to go for back surgery Monday so my days for repair r running low.-------I was considering sending the module out to be tested but its a 2 week turn around and ill be recovering then.------I have 2 others that r carbureted and much easier.---------how many volts should be at the coil primary wire?? thanks
    Last edited by xltier; 08-13-2013 at 09:08 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 virage wont run
    By normanjo in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-11-2016, 10:19 PM
  2. 2001 di wont run.polaris virage txi
    By xltier in forum Polaris Open Discussion
    Replies: 7
    Last Post: 09-20-2013, 01:40 PM
  3. 2001 di wont run.
    By xltier in forum Polaris Tech Tips and Info
    Replies: 0
    Last Post: 08-10-2013, 09:53 AM
  4. 2001 virage wont run
    By rxp127 in forum Polaris PWC Performance
    Replies: 26
    Last Post: 04-24-2010, 03:03 PM
  5. 2001 RX DI only runs when start is held
    By 2stroke in forum 2-Stroke Performance
    Replies: 9
    Last Post: 02-20-2008, 07:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •