Results 1 to 2 of 2
  1. #1

    1993 xp problems

    So here's the story: I have a 93 xp that had been sitting for 10 years. I got it running with help of a mechanic. We deleted the oil pump and mixed gas instead because the pump went bad. It had great compression and ran really well for a month. All of a sudden i'm riding one day and fall off in harsh water. I got back on and it wouldn't start but would turn over. The clicks became slower and slower until it wouldn't turn over anymore. I got a tow back to the house and tried to jump it thinking it was the battery. Even with it hooked up to power it wouldn't turn over at all. The prop moves up and down and can spin so the motor isnt locked up. Any ideas as to the problem?


  2. #2
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    Quote Originally Posted by Flyinian View Post
    So here's the story: I have a 93 xp that had been sitting for 10 years. I got it running with help of a mechanic. We deleted the oil pump and mixed gas instead because the pump went bad. It had great compression and ran really well for a month. All of a sudden i'm riding one day and fall off in harsh water. I got back on and it wouldn't start but would turn over. The clicks became slower and slower until it wouldn't turn over anymore. I got a tow back to the house and tried to jump it thinking it was the battery. Even with it hooked up to power it wouldn't turn over at all. The prop moves up and down and can spin so the motor isnt locked up. Any ideas as to the problem?
    Did the ski roll over too? If it did you may have hydro locked the engine, pull the plugs and make sure the battery is charged and try to see if it spits water out the cylinders. Since you jumped the ski you may have fried the mpem too. Hope what ever you jumped it from was not running.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 XP Problem...any ideas?
    By babyjoker494 in forum 2-Stroke Performance
    Replies: 7
    Last Post: 08-04-2008, 05:33 PM
  2. 93 seadoo xp problems
    By b93xp in forum 2-Stroke Performance
    Replies: 6
    Last Post: 06-17-2008, 11:07 PM
  3. 96 XP Problem
    By XPTEX in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 05-19-2008, 01:14 PM
  4. 97 xp problems
    By shawnIII in forum 2-Stroke Performance
    Replies: 5
    Last Post: 03-07-2008, 11:40 PM
  5. stock setting ?'S on 1993 xp
    By ugadawg131 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 05-30-2007, 05:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •