Results 1 to 4 of 4
  1. #1

    Polaris PWC 700 SLH

    I have a 2001 SLH 700 PWC that my son was riding yesterday and it just stopped. It seemed like the battery was dead. I was told that it might be something called the (Stader) and that it is expensive. If it was the Stador would machine turn over and start for a short time and then stop again. I charged the battery and it just wont even turn it over. Wondering if it might be something else like maybe the starter?


  2. #2
    ThrottleOut's Avatar
    Join Date
    Aug 2011
    Location
    Corning, NY
    Posts
    727
    +1
    29
    How did it 'just stop'? Were you close to shore? Possible that something got sucked into the jet pump?

    There are two types of stator's, one is an electrical one and the other is part of the jet pump. If you got a rock, stick, etc lodged in the jet pump stator/impeller it could prevent the engine from turning over.

    An electrical stator provides a charging circuit and signals for the ignition. While anything is possible, chances are it did not fail and lock up the motor.

    If it were me, I'd start by checking that the engine/driveline are free to rotate. Inspect the jet pump for any debris lodged in it and go from there. You could pull the plastic cover that covers the back side of the engine/crank and try to rotate the motor by hand. If you do this, unhook the battery first.

  3. #3
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by Corey View Post
    I have a 2001 SLH 700 PWC that my son was riding yesterday and it just stopped. It seemed like the battery was dead. I was told that it might be something called the (Stader) and that it is expensive. If it was the Stador would machine turn over and start for a short time and then stop again. I charged the battery and it just wont even turn it over. Wondering if it might be something else like maybe the starter?
    Welcome to the Hulk! Lots of good info here No quick answer, need to do some methodical testing as ThrottleOut has recommended.....

  4. #4

    Join Date
    Aug 2013
    Location
    Charlotte NC
    Posts
    4
    I'm having the same problem with my 97 slt750. Just stopped while under power, started right back up and did this a few times. Took it back to the dock and put in a new battery a week later and now it won't respond at all. Have you had any luck? I'm going to check some wiring this weekend, I'll let you know if I find the issue.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris 700 SLH wont crank properly at all times weird issue
    By Bdesim in forum Polaris Open Discussion
    Replies: 5
    Last Post: 09-10-2012, 12:37 AM
  2. Polaris 700 slh 2000 trim
    By ribamigr in forum Polaris Open Discussion
    Replies: 1
    Last Post: 05-29-2012, 07:53 AM
  3. Please help 99' polaris 700 slh won't start!!!
    By bullxi21 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-22-2011, 01:35 PM
  4. This PWC Any good??? Polaris SLT 700
    By Velislide in forum Polaris Open Discussion
    Replies: 16
    Last Post: 04-02-2008, 05:07 PM
  5. Ph2ocraft Extened Warranty For Polaris Pwc's In California
    By 2&4strokepolaristech in forum Polaris Open Discussion
    Replies: 3
    Last Post: 10-31-2006, 02:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •