Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1

    Join Date
    Aug 2013
    Location
    Fort Lauderdale
    Posts
    65
    +1
    3

    Does it look like my wear ring is missing (pic)

    I'm a newbie and purchased a 2000 Seadoo GTX RFI Millennium Edition, when I brought it to my dealer to get a second key made for it, the mechanic started looking things over and mentioned that the wear ring was missing, can you tell from the pic I posted if indeed it is missing

    here is a picture from the exhaust
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	image.jpg 
Views:	168 
Size:	75.6 KB 
ID:	310058  


  2. #2
    warsawspeedfreak's Avatar
    Join Date
    Jan 2010
    Location
    Tinley Park, IL
    Posts
    369
    +1
    19
    Hard to tell from your photo. Have you ridden it yet. When you hit the gas, does it go or rev up and sit there like you're doing a burnout? If it takes off and goes, its probably in there...Maybe worn from time but at least its there...

  3. #3
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    It's definitely missing! That's way to much day light around the prop.

  4. #4
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,851
    +1
    742
    Yep no wear ring and probably all kinds of other issues also!

  5. #5
    Don't know how many replies you want but something ain't right. To much light shining through...I would say it's gone or at least the rubber lining is gone.

  6. +1 by:


  7. #6

    Join Date
    Aug 2013
    Location
    Fort Lauderdale
    Posts
    65
    +1
    3
    It runs, seems like there is a little hesitation getting going, Thanks for the responses, I'm gonna bring it in to get looked at, he told me it was about a $250 repair

  8. #7
    bryantjopplin's Avatar
    Join Date
    Jun 2012
    Location
    Shreveport, LA
    Posts
    2,436
    +1
    163
    Pump looks like it might have a crack in it.

  9. #8
    pathfinder's Avatar
    Join Date
    May 2013
    Location
    Palm Harbor
    Posts
    104
    +1
    8
    holy missing wear ring batman!!!

  10. #9
    Q in Arizona's Avatar
    Join Date
    May 2013
    Location
    Phoenix, Az
    Posts
    30,542
    +1
    7,347
    Quote Originally Posted by normr View Post
    It runs, seems like there is a little hesitation getting going, Thanks for the responses, I'm gonna bring it in to get looked at, he told me it was about a $250 repair
    That sounds kinda high for a non ibr ski. I just had my wear ring done Saturday for $320 and that's on an ibs ski. You might want to call around.

  11. #10
    SuperCharged67's Avatar
    Join Date
    Jun 2012
    Location
    Halifax, NS, Canada
    Posts
    1,962
    +1
    76
    I would buy the wear ring and tackle the project myself

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Looking to purchase these.. Does it look like a good purchase?
    By Ponyboy in forum Sea Doo Open Discussion
    Replies: 18
    Last Post: 05-29-2015, 09:19 PM
  2. I know my wear ring is trashed, but how bout the prop?...
    By twokexlv6coupe in forum 4-Tec Performance
    Replies: 20
    Last Post: 06-20-2014, 06:44 AM
  3. Replies: 25
    Last Post: 04-06-2014, 08:56 PM
  4. 1996 SLT 780; It looks like my baby is going up for sale
    By TopCop931 in forum Polaris Open Discussion
    Replies: 14
    Last Post: 09-05-2012, 08:51 PM
  5. Replies: 4
    Last Post: 09-07-2010, 10:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •