Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 28
  1. #1
    Red Devil's Avatar
    Join Date
    Apr 2005
    Location
    Chesterfield/Richmond, VA
    Posts
    1,809

    Anti Sieze and Impeller

    Would applying anti sieze to the pump housing threads prior to installing the impeller have any effect on the impeller coming loose? I usually apply a little to that are and torque it down between 90 to 100 ft lbs anyway. Just wondering? That 58 lbs the manual recommends is BS....


  2. #2
    oklagp1200r's Avatar
    Join Date
    Nov 2005
    Location
    Newcastle, Oklahoma
    Posts
    2,888
    +1
    499
    Quote Originally Posted by Red Devil View Post
    Would applying anti sieze to the pump housing threads prior to installing the impeller have any effect on the impeller coming loose? I usually apply a little to that are and torque it down between 90 to 100 ft lbs anyway. Just wondering? That 58 lbs the manual recommends is BS....
    I was wandering what that torque was for the impeller to pump shaft!
    58lbs
    Anti sieze shouldnt hurt a thing!
    On my Kawi standups I use blue locktite instead!

  3. #3
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    isn't the direction off driveline always tightening the prop anyways? ... so it's gonna kidna torque it to a degreee on its own.

    i dont throw my entyire body into tightening the prop... but i go make it tight, then throw a quick shoulder into it and call it quits


    i've never used anti-seize personally, but i'm sure it's good practice... like msot of us, my props dont stay on the ski for very long before i take it back apart for either upgrades or mere boredom

  4. #4
    Red Devil's Avatar
    Join Date
    Apr 2005
    Location
    Chesterfield/Richmond, VA
    Posts
    1,809
    Quote Originally Posted by Shibby1485 View Post
    isn't the direction off driveline always tightening the prop anyways? ... so it's gonna kidna torque it to a degreee on its own.
    Hmmm, You know I never thought of that. I thought it was loosening it only because if you remember a while back my GTX almost sank because my prop almost spun off and my pump took on water. I actually removed the prop by hand when that incident happened and that is when I was only torquing to 58lbs.

  5. #5
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    prop loosened? that's not a common occurance

    i've heard of a few problems on only certain prop / pump combos

    "allegedly" there's a series of impeller shafts that have every so slightly different threads/diameter or whatever the flaw was.... and all the props are the same... so there's a few skis where props walked off the odd impeller shafts causing skis to sink and destroy wear rings and whatnot

  6. #6
    Red: I torqued the prop to 59lbs as in the manual and haven`t had a problem yet ... but I did use red loctite...PR...

  7. #7
    oklagp1200r's Avatar
    Join Date
    Nov 2005
    Location
    Newcastle, Oklahoma
    Posts
    2,888
    +1
    499
    Quote Originally Posted by Pale Rider View Post
    Red: I torqued the prop to 59lbs as in the manual and haven`t had a problem yet ... but I did use red loctite...PR...
    RED

  8. #8
    Matthew K ReDevilRXP's Avatar
    Join Date
    Aug 2006
    Location
    Lemont, IL
    Posts
    2,477
    I used anti seize on the prop threads a good amount to.I took of my prop about 10 times it was always tight and soon as u losend it the prop spun off by hand like butter.

  9. #9
    Quote Originally Posted by oklagp1200r View Post
    RED
    That`s what Skat originally put on when they did the tripple bearing mod, so I didn`t see any harm in it, besides you could always warm up the hub a bit...PR...

  10. #10
    oklagp1200r's Avatar
    Join Date
    Nov 2005
    Location
    Newcastle, Oklahoma
    Posts
    2,888
    +1
    499
    Quote Originally Posted by Pale Rider View Post
    That`s what Skat originally put on when they did the tripple bearing mod, so I didn`t see any harm in it, besides you could always warm up the hub a bit...PR...
    Very true but I wouldnt suggest it anyone to use the red!
    I have a Solas Kawi STXR prop desk collector to prove it! JMO

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ultra-300x Spark Plugs, Grease for Boots and Anti-Sieze
    By Spooling in forum Kawasaki Open Discussion
    Replies: 6
    Last Post: 06-30-2013, 06:54 PM
  2. New guy, and impeller/wear ring issues
    By mystahagy in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-17-2007, 11:05 PM
  3. RXP speeds vs rpm and impeller pitch
    By Vern in forum 4-Tec Performance
    Replies: 21
    Last Post: 02-10-2007, 11:35 PM
  4. wear ring and impeller ????
    By BJTKRXPHD in forum 4-Tec Performance
    Replies: 12
    Last Post: 07-22-2006, 06:34 AM
  5. Pump oil and impeller cones
    By Vern in forum 4-Tec Performance
    Replies: 4
    Last Post: 03-23-2006, 03:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •