Page 1 of 13 1 2 3 11 ... LastLast
Results 1 to 10 of 121
  1. #1
    nickflo7's Avatar
    Join Date
    Mar 2013
    Location
    Victoria tx
    Posts
    250
    +1
    1

    well found my problem on my 94 sl 750

    Click image for larger version. 

Name:	20130814_194031.jpg 
Views:	53 
Size:	158.5 KB 
ID:	310388pto
    Click image for larger version. 

Name:	20130814_194040.jpg 
Views:	53 
Size:	156.2 KB 
ID:	310389cen
    Click image for larger version. 

Name:	20130814_194050.jpg 
Views:	48 
Size:	149.1 KB 
ID:	310390mag

    thanks to the tec at watercraft superstore for giving me the wrong setting for the mag high speed fuel adjustment now my piston looks like this

    does anyone know where i can get a good pistol not to pricie and what size to get its going on a 94 polaris sl 750


  2. #2
    David Drkvampire2001's Avatar
    Join Date
    Jul 2011
    Location
    Edgerton, Wisconsin, United States
    Posts
    2,857
    +1
    30
    trying to think if I have a 750 piston...if i do it would for sure need new rings, or just get a WSM one. you will need to hone the cylinder. all of those pistons look lean. id fatten them all up some

  3. #3
    john zigler's Avatar
    Join Date
    Aug 2006
    Location
    WI
    Posts
    2,545
    +1
    33
    Have you rebuilt the carbs? updated the fuel system, triple outlet fuel pump, new lines, fuel select, etc?

    You may also have an air leak, I suggest a leak down test.

    your are DEFINATELY lean.

    I have new pistons, all needed gaskets, and fuel related parts in stock.

  4. #4
    ThrottleOut's Avatar
    Join Date
    Aug 2011
    Location
    Corning, NY
    Posts
    727
    +1
    29
    For reference here is his other thread: http://www.greenhulk.net/forums/showthread.php?t=204254

    In the future try to keep all of the same posts in one thread. It makes it much easier to follow so we can read through and see what you've already done. The more info we have the better we can help you.

  5. #5
    nickflo7's Avatar
    Join Date
    Mar 2013
    Location
    Victoria tx
    Posts
    250
    +1
    1
    Ok sorry guys it wouldn't let me get on this post so y'all think im running lean? I know for sure the mag cylinder I was. Had the wrong high speed screw setting it was only at 1/4 and not at 1 1/4 turn.

    On this photo can I pull the mag cylinder without pulling the exhaust out? Can I get the the back bolts (red arrows) and is it really hard its a 94 Polaris sl 750
    Click image for larger version. 

Name:	20130817_164213-picsay.jpg 
Views:	45 
Size:	131.0 KB 
ID:	310641

  6. #6
    nickflo7's Avatar
    Join Date
    Mar 2013
    Location
    Victoria tx
    Posts
    250
    +1
    1
    Yes I have done all the above

  7. #7
    David Drkvampire2001's Avatar
    Join Date
    Jul 2011
    Location
    Edgerton, Wisconsin, United States
    Posts
    2,857
    +1
    30
    you should be able to just unbolt the exhaust pipe and push it back some giving you the room to get to the bolts on the manifold

  8. #8
    nickflo7's Avatar
    Join Date
    Mar 2013
    Location
    Victoria tx
    Posts
    250
    +1
    1
    Ok sweet ill be working on that this afternoon thanks guys for the help and ill also try to be sure to stay on the feed lol

  9. #9
    nickflo7's Avatar
    Join Date
    Mar 2013
    Location
    Victoria tx
    Posts
    250
    +1
    1
    And also does anyone have the torque settings for the jugs bolts, head cover bolts, intake manifold Bolts, pretty much everything that needs torque

  10. #10
    Tony's Avatar
    Join Date
    May 2007
    Location
    North Carolina
    Posts
    1,760
    +1
    38
    Cyl. base 28ft/lbs
    Cyl. head 18ft/lbs
    Exhaust manifold 16ft/lbs
    Exh. pipe to manifold 45 ft/lbs
    Water manifold 78 in/lbs

    Click image for larger version. 

Name:	seq.JPG 
Views:	44 
Size:	22.8 KB 
ID:	310656

    Click image for larger version. 

Name:	exh.JPG 
Views:	36 
Size:	19.5 KB 
ID:	310657

    * Note the manual says 16ft/lbs for exh manifold but the figure lists 18 ft/lbs. Either should be sufficient.

Page 1 of 13 1 2 3 11 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Looks like water on sparkplug 94 sl 750 fuj enginei
    By Djaypro in forum Polaris Open Discussion
    Replies: 15
    Last Post: 08-31-2013, 09:46 AM
  2. Replies: 46
    Last Post: 08-30-2013, 09:22 PM
  3. removing the thermostat off my 94 sl 750
    By nickflo7 in forum Polaris Tech Tips and Info
    Replies: 10
    Last Post: 03-28-2013, 04:25 PM
  4. what kind of premix to run on a 94 sl 750
    By nickflo7 in forum Polaris How To & FAQs
    Replies: 23
    Last Post: 03-13-2013, 09:58 PM
  5. Pulling motor on my 95 sl 750
    By sidneypwc in forum Polaris How To & FAQs
    Replies: 7
    Last Post: 01-04-2012, 12:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •