Results 1 to 3 of 3
  1. #1

    waveraider 94 acceleration problem

    I recently bought 2 jet ski 94 waveraider
    with acceleration problems

    the first ski has
    erratic acceleration

    starts well and runs well
    when going to full throttle 55 MPH
    but cuts speed and starts again
    intermittent

    I clean the carb but not rebuild

    the second ski

    the problem I have with the second ski
    is that it does not exceed half throttle
    starts and runs strong up to half throttle
    but no further than that


  2. #2
    someone help me I'm out of idea

  3. #3
    did you ever figure this out? Second ski sounds like carb issues. Have you rebuilt them?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. waveraider 94 acceleration problem
    By skiraider in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 08-15-2013, 12:37 PM
  2. 2001 gp1200r acceleration problem??
    By 2000mustangMia in forum Yamaha Open Discussion
    Replies: 18
    Last Post: 04-13-2012, 02:08 PM
  3. SL 750 94' Engine problems
    By jfrelin in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-22-2008, 12:19 AM
  4. 94 750SL problems
    By TheRemedy in forum Polaris Open Discussion
    Replies: 3
    Last Post: 08-07-2007, 12:17 AM
  5. 1996 WaveRaider 700 Starting Problem
    By in-mn in forum Yamaha Old School Skis
    Replies: 3
    Last Post: 06-21-2007, 01:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •