Results 1 to 2 of 2
  1. #1

    2001 Kawasaki 900 STS - No CirClip or C-Clip Pump

    All,

    I'm struggling to find a c-clip for my 2001 Kawasaki 900 STS. I ordered a new seal and bearing kit for my pump housing and most of the packages one can buy on-line for this make/model do not contain a c-clip (only after I ordered mine, did I find some that had the clip included). What bugs me is that my manual states and references the c-clip yet all available parts diagrams on-line (see link as an example) do on make any mention of this clip.

    It seems I cannot simply order just the clip. I'm also not sure my machine had a clip when I removed everything. Has anyone else ha this problem? Do you think I can run it without the clip?

    Thanks!


    http://partsfinder.onlinemicrofiche....2&c=0-JET-PUMP


  2. #2
    TexasZ's Avatar
    Join Date
    May 2012
    Location
    Near San Antonio, Texas
    Posts
    460
    +1
    34
    Quote Originally Posted by N2Motors View Post
    All,

    I'm struggling to find a c-clip for my 2001 Kawasaki 900 STS. I ordered a new seal and bearing kit for my pump housing and most of the packages one can buy on-line for this make/model do not contain a c-clip (only after I ordered mine, did I find some that had the clip included). What bugs me is that my manual states and references the c-clip yet all available parts diagrams on-line (see link as an example) do on make any mention of this clip.

    It seems I cannot simply order just the clip. I'm also not sure my machine had a clip when I removed everything. Has anyone else ha this problem? Do you think I can run it without the clip?

    Thanks!


    http://partsfinder.onlinemicrofiche....2&c=0-JET-PUMP
    Is your manual put out by Kawasaki or some other company?
    There is no clip.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 30
    Last Post: 02-19-2017, 02:54 PM
  2. Replies: 2
    Last Post: 08-15-2013, 07:48 AM
  3. 2001 Kawasaki 900 STS - Hesitates at ~4500 RPMs
    By N2Motors in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 07-25-2013, 10:19 PM
  4. Kawasaki 900 sts 2001
    By johnny2270 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 8
    Last Post: 06-07-2012, 10:17 PM
  5. 2001 Kawasaki 900 STS - MFD Not Working w/ New Display
    By travishansen in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 05-07-2011, 10:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •