Results 1 to 9 of 9
  1. #1

    Join Date
    Aug 2013
    Location
    Panama City Beach FL
    Posts
    26

    Engine exhaust Overheating 2007 RXP - help

    Ski is flushed after each use in salt and bay water. Exhaust hi temp alarm likes to go off at WOT. It seems the problem of not getting enough water in exhaust. Other threads have suggested installing water strainer at intake side to intercooler, or flushing or testing intercooler for debris. Also suggested on forum, drilling ports holes larger at exhaust / J pipe. Wondering if water strainer will help or slow water flow intake, will drilling out these holes to j pipe help (not sure). Currently I am using salt away flushing attachement to help. also, have not pulled intercooler yet. I am sure many others are having this issue also. Thanks.


  2. #2
    SJL Custom's Avatar
    Join Date
    Jun 2008
    Location
    Toronto, Ontario
    Posts
    253
    +1
    10
    Exhaust temp sensor is located in the exiting port of the oem waterbox. Water enters the exhaust stream from the j-pipe into the waterbox through the three pissers. Remove the j-pipe and check those three holes first. Make sure they aren't blocked with any debris etc. Be sure to flush it out as much as possible while you have it out. If warning still exists, pull the exhaust manifold off next and check it for salt buildup etc. While you have the Exhaust manifold off, you can back flush the intercooler as well.

    You have to be careful if the warning persists. The excessive exhaust temps will melt the plastic components (Resonator, Exhaust Tip) and cause the ski to sink. Ask how I know lol

  3. #3
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Sounds like you've got some blockage in the exhaust cooling pissers or a bad exhaust sensor...

  4. #4
    Sammynels's Avatar
    Join Date
    Jul 2013
    Location
    Swansea, MA.
    Posts
    45
    +1
    1
    Check your clamps on your water box. I bet a clamp either broke or is loose.

  5. #5

    Join Date
    Aug 2013
    Location
    Panama City Beach FL
    Posts
    26
    Thanks.. I will pull the J-pipe if necessary. Have anyone enlarged these pisser holes at all ? The dealer said their is a small hose under the j pipe that gets clogged also, not easy to get at, without pulling j-pipe, not sure the function of that hose. Thanks for all responses !

  6. #6
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    475
    the hose out the top of the J pipe is a water outlet
    if you pinch off that hose you will increase the water going to the waterbox/muffler

  7. #7
    SuperCharged67's Avatar
    Join Date
    Jun 2012
    Location
    Halifax, NS, Canada
    Posts
    1,962
    +1
    76
    What would happen when you increase the water going through the waterbox/muffler? I to have the same problem and that line was clogged for me.

  8. #8
    jbombino's Avatar
    Join Date
    Jun 2007
    Location
    Hialeah, FL
    Posts
    636
    +1
    17
    Check and make sure that the 2.75 hose that goes between j-pipe and the water box is properly connected.
    If the upper SS clamp is too low then it could block the water passage and give you heat/exhaust temperature.

  9. #9
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    Check your pump make sure your plastic filter nut did not come off you will have little to no water pressure

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Check engine on my 04 rxp. Help plz
    By Fuzzy8 in forum 4-Tec Performance
    Replies: 7
    Last Post: 05-31-2016, 02:56 PM
  2. 2007 RXP: Help Removing Side Panels
    By NastyStang in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 08-27-2014, 09:48 PM
  3. 2007 rxp help
    By gba in forum 4-Tec Performance
    Replies: 12
    Last Post: 04-24-2013, 07:13 AM
  4. Random RPM loss 2007 rxp HELP
    By skingelo in forum 4-Tec Performance
    Replies: 14
    Last Post: 07-18-2012, 07:26 PM
  5. WTB free flow exhaust for 2007 RXP
    By toilets in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 07-30-2009, 09:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •