Results 1 to 8 of 8
  1. #1

    Join Date
    Oct 2011
    Location
    Metairie louisiana
    Posts
    98

    problems with rebuild

    Rebuilding rxp215 new pistons old rods if i leave the rod caps loose i can turn the crank if i torque the rod bolts then it wont turn rods are in same spot even tried old rod bearings same problem


  2. #2
    Where did you buy the bearings? Did you seat them in the caps properly? Were they perfectly clean before installation? You cannot have anything between cap and shell, not even oil.

  3. +1 by:


  4. #3

    Join Date
    Oct 2011
    Location
    Metairie louisiana
    Posts
    98
    bought bearings from sbt
    even with the old bearings everything cleaned bearing surface lubed cant get crank to turn when rods tightnend

  5. #4
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198
    Aren't sbt bearings oversized?

  6. #5
    mikelytle1077's Avatar
    Join Date
    Sep 2010
    Location
    frisco, tx
    Posts
    955
    +1
    37
    Sbt std bearings are over by 10 thousand I advise not to run them unless you get the whole kit that comes with under sized ones. Did you spin a bearing?

  7. #6
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    I think you found your issue...

  8. #7
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,182
    +1
    98
    Quote Originally Posted by wotxxxsd View Post
    I think you found your issue...

    How so? He put the OLD bearings in and it still won't turn. So how does that blame the new SBT ones!

  9. #8
    mikelytle1077's Avatar
    Join Date
    Sep 2010
    Location
    frisco, tx
    Posts
    955
    +1
    37
    i think maybe he spun a rod bearing and it deformed the cap it happened to me get a new rod if thats the case. also with sbt std bearings oil clearance was right at 10 thou the factory calls for .0035 oil clearance on the rods.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Stumped-Problem with a 1995 657X Carb Rebuild
    By scooter123 in forum 2-Stroke Performance
    Replies: 14
    Last Post: 10-10-2007, 06:09 AM
  2. Help! - Problem with RXT front hood
    By BrAinZ in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 11-17-2005, 05:55 PM
  3. Problems with Sea doo rxt
    By Murrbig in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 09-14-2005, 09:11 AM
  4. Problem with performance adds???????
    By terryt in forum 4-Tec Performance
    Replies: 16
    Last Post: 07-31-2005, 04:00 PM
  5. Found my Problem with My RXP after Service.
    By Water4fire in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-20-2005, 03:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •