Results 1 to 10 of 10
  1. #1

    06 RXP Wont start just clicks

    Hey guys, I cant seem to figure out what the issue is.... When I try to start the ski it will just click once or click repetitively. I had the battery tested and it is good. I replaced the starter solenoid but I am still having the same problem. I cleaned the contacts on the battery.... I'm starting to think maybe its the starter?
    Its completely random though, sometimes it will start right up sometimes it wont start at all. I can get it running in the driveway, I bring it down to the launch and it wont start. I am getting very frustrated.....


  2. #2
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Are you sure the relay you put in was good??
    I've seen multiple bad relays.
    Try jumping the posts on the relay with a metal object.
    If it turns over when jumped then its the relay.
    If not then its probably your starter.

  3. #3
    I thought that too after posting this thread. However, instead of jumping the posts I pulled the cables off and touched them toghether. When I touched them together the ski cranked but didnt start I did it one other time it did the same thing and I got a steady beep out. So I stopped I put the cables back on and went to start it normally and nothing... Now I dont even get a beep when I put the key on the display loads but thats it. I checked the fuses they are all ok. I tested the battery and it was low. Im assuming that I killed the battery trying to get it started the whole time. Im hoping thats the issue and I didnt fry anything. Im not sure how I could have but I dont know. Im charging the battery now...

    However when I touched the cables together it cranked so would that be another bad relay? It didnt start though so could that be the starter or do I have the trifecta going between the started relay and batter haha...

  4. #4
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Sounds like another bad relay or battery.

  5. #5
    I went and got another relay put it in but im still getting nothing. The battery tests good but when I put the key in it is drops to bad. I bought another battery but it has to do its initial charge. The battery that I took out tests fine on the bench. I might try and throw it in my other ski to see what happens. If it works fine in the other ski I might have a bigger problem?

  6. #6
    WOO HOOOOOOOOO I replaced the starter relay and put the other batter from the other ski in it and it fired right up..... I guess it was a defective relay and a dead or dying battery. As soon as the new battery is done with its initial charge I should be all set to go. Thanks for your help wotxxxsd!

  7. #7
    Rick's Avatar
    Join Date
    Jul 2007
    Location
    Long Island, New York
    Posts
    19
    Sounds like my day so far.
    my 2007 RXT will not start.
    New battery, 2ed starter relay IN 3 WEEKS, cleaned 5 gounding connections, checked fuse.
    put wire from neg. on battery to engine lift on engine. Started a few times, screw drivered between relay started a few times.
    All together I get no click at all.
    New stator last year. 3ed battery in 1 year, new voltage reg.
    Still ng.

  8. #8
    Rick's Avatar
    Join Date
    Jul 2007
    Location
    Long Island, New York
    Posts
    19
    Congrads

  9. #9
    That sucks... At least mine was simple. Frustrating when its more then one thing because its hard to diagnose. If this didnt work today it was going into the shop. I just got my other back from the shop. The intercooler leaked so badly it hydrolocked the motor.... That wasnt fun either...

    Quote Originally Posted by Rick View Post
    Sounds like my day so far.
    my 2007 RXT will not start.
    New battery, 2ed starter relay IN 3 WEEKS, cleaned 5 gounding connections, checked fuse.
    put wire from neg. on battery to engine lift on engine. Started a few times, screw drivered between relay started a few times.
    All together I get no click at all.
    New stator last year. 3ed battery in 1 year, new voltage reg.
    Still ng.

  10. #10
    Rick I see your also in LI. If your frustrated and looking for a reputable shop. Call Carl from Island Racing. They are in Baldwin (516) 546-0090. He never answers the phone but leave a message and hell call you back. Hes the one who fixed my intercooler issue

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP Wont Start! New relay and battery just clicks!
    By nimick in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 06-01-2014, 08:28 PM
  2. zxi 1100 wont start, just clicks, tested starter motor good.
    By boostintt in forum Kawasaki Open Discussion
    Replies: 6
    Last Post: 06-06-2012, 06:20 PM
  3. 06 GTX SC won't start-just clicks
    By Folly77 in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 02-25-2011, 03:48 PM
  4. 06 RXP wont start?
    By Stainless in forum 4-Tec Performance
    Replies: 4
    Last Post: 06-03-2009, 09:09 AM
  5. 06 Rxp wont start
    By Antiguan FZR in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 03-31-2008, 04:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •