Page 1 of 9 1 2 3 ... LastLast
Results 1 to 10 of 84
  1. #1
    Boost-A-Holic's Avatar
    Join Date
    Jul 2012
    Location
    Dallas, Texas, United States
    Posts
    1,173
    +1
    94

    Snap Crackle Pop.....

    So im WOT at like 8440 tryin to walk down mike when all of a sudden my ski kinda hesitated/stuttered 2-3 times real quick. I noticed it so i looked down at my AFRs to see what was goin on and just as quickly as it started to stutter it just shut off completely. Tried to crank but would barely even turn the motor. Mike towed my ass back to the loading ramp and we got her back on the trailer. Very possible that i had a SC bearing failure.

    I do beat up my ski and run it pretty dang hard but ive never had any problems. I had a passenger riding with me for the first time since i did all the mods and im wondering if the additional weight put some strain on my ski and contributed to all that happening. Im sure dig runs and WOT stretches with a passenger didnt help much either lol.

    Click image for larger version. 

Name:	broke ski.jpg 
Views:	117 
Size:	51.1 KB 
ID:	310771


  2. #2
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,062
    +1
    790
    Man Sorry to here this. Ofcoarse start by pulling SCer, pump, Valvecover. Inspect and hope for the Best. Ray Sundance had all 3 of his cam gear bolts shear this weekend also. SO look there aswell, but I will hope for the best for ya. BUT I will be pulling Rays head and sending it out to Chris for some Love on a couple valves. Good Luck!

  3. #3
    Boost-A-Holic's Avatar
    Join Date
    Jul 2012
    Location
    Dallas, Texas, United States
    Posts
    1,173
    +1
    94
    Quote Originally Posted by Water4fire View Post
    Man Sorry to here this. Ofcoarse start by pulling SCer, pump, Valvecover. Inspect and hope for the Best. Ray Sundance had all 3 of his cam gear bolts shear this weekend also. SO look there aswell, but I will hope for the best for ya. BUT I will be pulling Rays head and sending it out to Chris for some Love on a couple valves. Good Luck!

    i really hope its not too bad. It shut off pretty much instantly so maybe that helps my cause a bit.

  4. #4
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,062
    +1
    790
    Well Rays Shut off instantly, but it still bent some valves. My 2010 TX 260 had a SCer failure at 65hours. I found all the bearings and most of the polymere cage was in the front pump. Let us know what you find!

  5. #5
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by Boost-A-Holic View Post
    i really hope its not too bad. It shut off pretty much instantly so maybe that helps my cause a bit.
    Damn man that sucks.....A ski i rode droppped a valve and it did the same thing...shuttered and within a second shut down and would not turn over again...it took out the head and piston..hopefully yours is something simple....

  6. #6
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    hope it's something simple!

  7. #7
    mikelytle1077's Avatar
    Join Date
    Sep 2010
    Location
    frisco, tx
    Posts
    955
    +1
    37
    i pulled the plugs and and it spun over but heard some noise coming from the pto

  8. #8
    Chupacobra's Avatar
    Join Date
    Jun 2012
    Location
    Orlando, FL
    Posts
    1,369
    +1
    408
    Even tho i do not post much I follow you guys a ton! makes me sad when some thing like this happens to ya'll

  9. #9
    Boost addict hotbird's Avatar
    Join Date
    Jul 2011
    Location
    Southern WI
    Posts
    5,503
    +1
    681
    Flywheel bolts. Valve dropped??

    Sorry man. Hope its a easy fix.

  10. #10
    Boost addict hotbird's Avatar
    Join Date
    Jul 2011
    Location
    Southern WI
    Posts
    5,503
    +1
    681


    Hope you dident copy what I did here.

Page 1 of 9 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Another Snap Crackle Pop for a Texas rider
    By skigolfnut in forum 4-Tec Performance
    Replies: 10
    Last Post: 08-20-2013, 01:36 AM
  2. I snapped!!
    By sprchrgd89gt in forum Sea Doo Open Discussion
    Replies: 14
    Last Post: 06-01-2009, 12:01 AM
  3. Snap On Torque Wrench
    By Green Hulk in forum 4-Tec Performance
    Replies: 48
    Last Post: 12-24-2006, 09:06 PM
  4. pop off valve
    By seadoolover in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-12-2006, 06:54 AM
  5. popped my oil change cherry
    By Lurker in forum 4-Tec Performance
    Replies: 9
    Last Post: 08-26-2005, 09:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •