Results 1 to 7 of 7
  1. #1

    throttle response

    Hi all I have a 96 seafood XP 800. I had a fuel issue with it originally. So I rebuild the carbs and changed the grey fuel lines and cut the spark plug wire back and that fixed the problem. But now when I'mat idle and hammer it to fuel throttle it is delayed reaction for a second then it goes full out.any support would be greatly. Appreciated


  2. #2
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    carb issue...did you adjust anything after the fact? pop off pressure may be wrong. could be a needle and seat sticking or dirty filters in the carbs

  3. #3
    I changed the old filters and installed a inline fuel filter.I also reused the old spring so I wouldn't change the pop off preaure and I didn't mess with any adjustment.

  4. #4
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    Quote Originally Posted by cerberus6805 View Post
    I changed the old filters and installed a inline fuel filter.I also reused the old spring so I wouldn't change the pop off preaure and I didn't mess with any adjustment.
    are the needle and seats new or original?

  5. #5

  6. #6
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    That is where I would start. Replace those and see if it goes away

  7. #7
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    2,773
    +1
    130
    I would start by opening the low speed needles 1/2 turn more than they are now.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Variable/uneven throttle response on Ficht 2002 Virage TXi
    By K447 in forum Polaris Open Discussion
    Replies: 40
    Last Post: 05-25-2013, 10:33 AM
  2. SLX 1050 throttle response problem revisited, with video
    By absentx in forum Polaris Open Discussion
    Replies: 62
    Last Post: 05-24-2010, 08:56 AM
  3. Throttle response....
    By maxdoc in forum 2-Stroke Performance
    Replies: 5
    Last Post: 09-18-2008, 10:45 AM
  4. Throttle Responsiveness
    By mikeysso in forum 2-Stroke Performance
    Replies: 5
    Last Post: 08-07-2008, 11:02 AM
  5. 95 SL750 Poor Throttle Response
    By christian79 in forum Polaris Open Discussion
    Replies: 12
    Last Post: 08-14-2007, 11:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •