Results 1 to 6 of 6
  1. #1

    speedometer problems, HELP

    I have a 07 RXP, and currently have the cowels and the seat taken off trying to trace back the speedo wires back to something. im having problems finding out whats going on. The gage started jumpin (going up an down) while I was doing about 35 on my last ride. I know a GPS is a better way to track speed, I just want the gage to work bc it is annoying


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Check the paddle wheel on the back.

  3. #3
    ive been tryin to find it. its on the inner right side of the hull right?

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Outside the hull on the right side black triangle thingy.

  5. #5
    ok. I found the wheel.. it had a broken paddle and it seems like the pin is too short to hold it in place. when I reassembled the triangle thing it wont hold the pin far enough to keep the wheel from falling out of the other side. can I order a new paddle and pin from this site?

  6. #6

    Join Date
    Jan 2009
    Location
    Scotland, UK
    Posts
    290
    +1
    9
    Quote Originally Posted by riverrat09 View Post
    ok. I found the wheel.. it had a broken paddle and it seems like the pin is too short to hold it in place. when I reassembled the triangle thing it wont hold the pin far enough to keep the wheel from falling out of the other side. can I order a new paddle and pin from this site?
    I dont think you can buy the paddle wheel and the pin as separate items....you need to buy the whole speed sensor or try and find a used one on e-bay. You might be able to get the parts you need from an old one.
    The oem part No for a new speed sensor for your model is 278001993 and it`s priced at $76.99 in the store. It is a bit expensive when you only need the paddle wheel and pin but the new sensor comes with the wires attached so you just connect it to the wiring loom on the ski.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. R&D grate Defective or no problem??? Help...
    By Tiburon in forum 4-Tec Performance
    Replies: 3
    Last Post: 09-24-2006, 06:45 PM
  2. Cavitation Problem? Help!
    By NeverEndn in forum 4-Tec Performance
    Replies: 41
    Last Post: 08-10-2006, 10:01 PM
  3. Weird voltage drop problem help!
    By NateGP1300R in forum Yamaha PWC Performance (2-stroke)
    Replies: 33
    Last Post: 07-29-2006, 08:08 PM
  4. RXP problems... help
    By mgo7483 in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 07-03-2006, 06:13 PM
  5. GP1200R Problems - HELP!!!
    By ramnj in forum Yamaha PWC Performance (2-stroke)
    Replies: 47
    Last Post: 06-05-2006, 08:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •